Bug 243760 - Intel driver on Thinkpad T60 breaks video playback
Intel driver on Thinkpad T60 breaks video playback
Status: CLOSED DUPLICATE of bug 239125
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
7
All Linux
high Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 14:52 EDT by Bryan Che
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 19:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my xorg.conf file (1.08 KB, application/octet-stream)
2007-06-21 19:02 EDT, Bryan Che
no flags Details
/var/log/Xorg.0.log (65.66 KB, text/plain)
2007-06-21 19:04 EDT, Bryan Che
no flags Details
/var/log/Xorg.setup.log (994 bytes, text/plain)
2007-06-21 19:05 EDT, Bryan Che
no flags Details
/var/log/Xorg.0.log after removing xorg.conf (71.93 KB, text/plain)
2007-06-21 19:13 EDT, Bryan Che
no flags Details
/var/log/Xorg.0.log (88.49 KB, text/plain)
2007-06-26 05:22 EDT, Casual J. Programmer
no flags Details
/etc/X11/xorg.conf (1.54 KB, application/octet-stream)
2007-06-26 05:23 EDT, Casual J. Programmer
no flags Details

  None (edit)
Description Bryan Che 2007-06-11 14:52:43 EDT
Description of problem:

I have a Thinkpad T60 with Intel 945 integrated graphics.  F7 selected the Intel
driver by default.  This driver doesn't play back video.  For example, I did a
yum install of xine, and xine immediately crashes upon launch.  Other video
players also have problems.

I switched to the 810 drivers instead, and I was able to play back video fine.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-7.fc7
xine-0.99.5-1.fc7

How reproducible:
very

Steps to Reproduce:
1. use intel drivers on T60
2. launch xine
3. 
  
Actual results:
xine crashes immediately

Expected results:
xine runs


Additional info:
Comment 1 Adam Jackson 2007-06-15 17:07:10 EDT
What version of xorg-x11-drv-i810 ?
Comment 2 Bryan Che 2007-06-15 17:09:10 EDT
xorg-x11-drv-i810-2.0.0-3.fc7
Comment 3 Matěj Cepl 2007-06-19 12:13:10 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Bryan Che 2007-06-21 19:02:46 EDT
Created attachment 157582 [details]
my xorg.conf file
Comment 5 Bryan Che 2007-06-21 19:04:33 EDT
Created attachment 157583 [details]
/var/log/Xorg.0.log
Comment 6 Bryan Che 2007-06-21 19:05:21 EDT
Created attachment 157584 [details]
/var/log/Xorg.setup.log
Comment 7 Bryan Che 2007-06-21 19:06:03 EDT
This is the error message I get when running xine from the command line:

This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.
AFD changed from -2 to -1
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  140 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  2363
  Current serial number in output stream:  2364
Comment 8 Bryan Che 2007-06-21 19:06:55 EDT
I have since yum updated to xorg-x11-drv-i810 and still get the same problems
Comment 9 Bryan Che 2007-06-21 19:13:13 EDT
Created attachment 157586 [details]
/var/log/Xorg.0.log after removing xorg.conf

This is the log file after I deleted xorg.conf and let my system auto-detect
Comment 10 Casual J. Programmer 2007-06-26 05:22:41 EDT
Created attachment 157857 [details]
/var/log/Xorg.0.log
Comment 11 Casual J. Programmer 2007-06-26 05:23:23 EDT
Created attachment 157858 [details]
/etc/X11/xorg.conf
Comment 12 Casual J. Programmer 2007-06-26 05:35:32 EDT
On a Fujitsu Siemens Amilo Si 1520 with Intel GM945 graphics and Quanta Display
15" 1280x800 Display the same problem exists.

Fedora7 is 2.6.21-1.3228.fc7, xorg-x11-drv-i810-2.0.0-4.fc7

Xine plays DVDs , sound is audible but the display window is black. Setting
"System/Preferences/Hardware/Screen Resolution" to 1024x768 from 1280x800 breaks
the display completely, the screen goes black.

When changing driver from "intel" to "i810" everything seems fine.

As the "intel" driver is described as "Experimental", I wonder how it got to be
the driver for the final release.

It may be of interest for you, that the same driver is causing problems with
openSuSE 10.3 alpha as well, only Xine seems to work correctly.

Comment 13 Matěj Cepl 2007-06-26 08:06:40 EDT
Casual J. Programmer, could you please attach to this bug your
/etc/X11/xorg.conf and /var/log/Xorg.0.log as uncompressed separate attachments
as well? Thank you.
Comment 14 David Hollis 2007-06-27 02:02:46 EDT
xorg-x11-drv-i810-2.0.0-4.fc7 seems to fix this.  Mplayer now works fine for me
using the Xv driver instead of X11.

From the changelog:
* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
  965GME, G33, Q33, and Q35 chips.
Comment 15 Casual J. Programmer 2007-06-27 11:36:07 EDT
Re: Comment #13

See Comment #10 and Comment #11
Comment 16 Jeffrey Ross 2007-07-09 20:56:18 EDT
X is locking up, the system continues to run and it accessible via the network,
but a CTRL-ALT-BKspace does not restore the X session.

I found in the /var/log/Xorg.0.log.old the following:

(II) AIGLX: Suspending AIGLX clients for VT switch
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x7ef80001 pgetbl_err: 0x0
ipeir: 0 iphdr: bf089b31
LP ring tail: 700 head: 0 len: 1f001 start 0
Err ID (eir): 0 Err Status (esr): 1 Err Mask (emr): ffffffdf
instdone: ffe5fafd instdone_1: fffff
instpm: 0
memmode: 0 instps: 8001e022
HW Status mask (hwstam): fffedffe
IRQ enable (ier): 2 imr: fffe0000 iir: 80
acthd: 2dd8024 dma_fadd_p: 2dd8100
ecoskpd: 307 excc: 0
cache_mode: 6800/180
mi_arb_state: 44
IA_VERTICES_COUNT_QW 0/0
IA_PRIMITIVES_COUNT_QW 0/0
VS_INVOCATION_COUNT_QW 0/0
GS_INVOCATION_COUNT_QW 0/0
GS_PRIMITIVES_COUNT_QW 0/0
CL_INVOCATION_COUNT_QW 0/0
CL_PRIMITIVES_COUNT_QW 0/0
PS_INVOCATION_COUNT_QW 0/0
PS_DEPTH_COUNT_QW 0/0
WIZ_CTL 0
TS_CTL 0  TS_DEBUG_DATA fef7fdf6
TD_CTL 0 / 0
space: 129272 wanted 131064

FatalError re-entered, aborting
lockup


The motherboard is an Intel DG965RY with a built in video card lspci reports the
VGA controller as:
00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics
Controller (rev 02)

One of the screen savers is triggering the bug as it just started happening
after I loaded a bunch of screensavers and set it to randomly choose one, plus
it only happens when the system brings up a screensaver.

In addition I have noticed that I can not play  video's with mplayer which by
default uses xv (?) unless I specify "-vo x11"  in FC6 I didn't have this issue.

switching to the i810 driver from the Intel experimental driver solves the problem
Comment 17 Adam Jackson 2007-07-10 09:52:13 EDT
(In reply to comment #16)
> X is locking up, the system continues to run and it accessible via the network,
> but a CTRL-ALT-BKspace does not restore the X session.

What version of the i810 package do you have installed?
Comment 18 Jeffrey Ross 2007-07-10 11:49:51 EDT
(In reply to comment #17)
> (In reply to comment #16)
> > X is locking up, the system continues to run and it accessible via the network,
> > but a CTRL-ALT-BKspace does not restore the X session.
> 
> What version of the i810 package do you have installed?

When the X freezes I'm using the experimental intel driver as autodetected by
the Fedora 7 installer "Intell - Experimental modesetting driver for Intel
integrated graphics chipsets"

When I switch to the i810 driver it works, that is:
(II) LoadModule: "i810"
(II) Loading /usr/lib64/xorg/modules/drivers//i810_drv.so
(II) Module i810: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.6.5
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2

the Experimental driver, the one that was failing, I am not using now was the
one distributed with F7 - x86_64

Comment 19 Juan Pablo Salazar Bertin 2007-08-15 19:26:34 EDT
This is a duplicate of bug #239125.
Comment 20 Matěj Cepl 2007-08-15 19:37:06 EDT

*** This bug has been marked as a duplicate of 239125 ***

Note You need to log in before you can comment on or make changes to this bug.