Bug 243762 - glibc issue invalid pointer on free()
Summary: glibc issue invalid pointer on free()
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: PyQt   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-11 18:58 UTC by Jochen Schmitt
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 15:58:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace of the python issue (5.97 KB, text/plain)
2007-06-11 19:21 UTC, Jochen Schmitt
no flags Details

Description Jochen Schmitt 2007-06-11 18:58:53 UTC
Description of problem:


Version-Release number of selected component (if applicable):
python-2.5


How reproducible:
Start luma
open browser
click on plus button of the server

  
Actual results:
*** glibc detected *** python: free(): invalid pointer: 0x00002aaaaab1b418 ***

Programm hangs

Expected results:
Normal working

Additional info:
This issue occured von python-2.5.1 (cvsI too.

Orignal bug is #221167

Comment 1 Jeremy Katz 2007-06-11 19:14:22 UTC
This is almost certainly not a python bug and instead a bug in one of the
bindings used by luma.  Python2.5 changes things so that you must consistently
use either PyObject or PyMem allocation rather than mixing and matching between
the two.  

Would need a backtrace with -debuginfos installed to get a better idea of which
is the causer.  Or a good way to set up luma to use it.

Comment 2 Jochen Schmitt 2007-06-11 19:21:07 UTC
Created attachment 156750 [details]
Backtrace of the python issue

Comment 3 Jeremy Katz 2007-06-11 19:42:15 UTC
Okay, that's coming from PyQT (or what's generated by sip)

Comment 4 Jochen Schmitt 2007-06-12 15:58:35 UTC
I have found out, that the issue was raise by python-ldap. After a update to
python-ldap-2.3 the issue doesn't occure anymore.


Note You need to log in before you can comment on or make changes to this bug.