Bug 243779 - Starting 2nd server with 1=Standard in custom.conf no longer works
Starting 2nd server with 1=Standard in custom.conf no longer works
Status: CLOSED DUPLICATE of bug 243551
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 17:00 EDT by Matthew Miller
Modified: 2008-05-13 15:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 15:19:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2007-06-11 17:00:27 EDT
Description of problem:

Starting multiple servers no longer seems to work.



Version-Release number of selected component (if applicable):

gdm-2.19.2-1.fc8 (may have started sooner, but not too long ago)

How reproducible:

Every time.

Steps to Reproduce:
1. Put 1=Standard in the [servers] section of /etc/gdm/custom.conf
2. restart
  
Actual results:

Just one X server and gdm greeter on virtual console 7.

Expected results:

One X server and gdm greeter on vc7 and one on vc8. (By default, of course.)

Additional info:

This has worked for years -- fast user switch before anyone else had it. But now
it suddenly stopped working.
Comment 1 Damian Wrobel 2007-07-25 17:55:05 EDT
I have the same observation using the gdm-2.19.4-1.fc8, but it's enough to
replace just the gdm-binary from the gdm-2.18.0-9.fc7 package and it works again.
Comment 2 Matthew Miller 2007-07-25 18:53:28 EDT
As a workaround, I ended up doing this:

[servers]
0=A
1=B

[server-A]
name=Desktop A
command=/usr/bin/X :0 -br -audit 0 vt7
flexible=true

[server-B]
name=Desktop B
command=/usr/bin/X :1 -br -audit 0  vt8
flexible=true

Which works fine.
Comment 3 Damian Wrobel 2007-11-12 16:57:55 EST
The aforementioned workaround, as given in comment #2, stopped to working after
upgrade to gdm-2.21.2-0.2007.11.09.1.fc9.
Comment 4 Matthew Miller 2008-03-07 20:42:13 EST
Yeah, so, uh, any word from gdm developers about this? It's a pretty major
regression.
Comment 5 Matthew Miller 2008-04-21 22:43:38 EDT
This still fails with gdm-2.21.10-0.2008.04.11.3.fc9 in Rawhide.
Comment 6 Matthew Miller 2008-05-13 15:19:45 EDT
Oh, hey. This is a dupe of bug #243551.

*** This bug has been marked as a duplicate of 243551 ***

Note You need to log in before you can comment on or make changes to this bug.