Bug 243799 - MBR gets installed in sda despite unchecking sda as a disk to install on, unsafe defaults
MBR gets installed in sda despite unchecking sda as a disk to install on, uns...
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Martin Sivák
Depends On:
  Show dependency treegraph
Reported: 2007-06-11 18:58 EDT by Tracy R Reed
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-21 03:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tracy R Reed 2007-06-11 18:58:47 EDT
Description of problem:

I intended to install Fedora-7-i386 onto an external USB2 hard drive attached to
a laptop running Windows Vista on a new Sony VAIO laptop. During the install it
asked me which drives to use. I unchecked sda. I double, triple, and quadruple
checked it. I didn't want anything to touch sda. Everything looked good and the
install proceeded as normal. I configured the BIOS to boot the USB2 first if
attached and then the internal HD. Everything worked when the machine booted up
off of the USB2 drive. I removed the USB drive and rebooted the laptop expecting
to see Vista. I got a GRUB prompt instead. And then it hung. Apparently anaconda
installed the MBR onto sda anyway. I booted the F7 install DVD on another
machine and noticed that only under the advanced options does it let me specify
where to put the MBR. This violates the principle of least surprise, to say the
least. The second stage GRUB and everything else got installed onto the
removable device and the MBR went onto the internal HD. This is a useless

Once you have wiped out the Vista MBR it is near impossible to replace. Gone are
the days when you can just do fdisk /mbr. Supposedly you can run bootsect.exe
from the install media but this laptop didn't come with install media as so many
don't. I managed to get a copy from a friend and I got "Access denied" trying to
run it even with administrator rights. We even tried restoring the whole OS from
the recovery partition which didn't restore the MBR. So yeah, it sucks.

Did I mention this was my gf's laptop which I just trashed?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot F7 installed with external USB2 device
2. Uncheck sda leaving sdb checked for the install
3. After the install notice that you have an unusable bootload setup
Actual results:

GRUB is installed on sda. Stage two installed on SDB. You can't get into Vista.

Expected results:

GRUB installed only on sdb. sda is completely untouched. When booted off of sda
via BIOS Vista boots. When booted off of sdb F7 boots.

Additional info:
Comment 1 NILMONI DEB 2007-07-27 13:35:16 EDT
I think the title of the report should be "Bootloader gets installed to MBR in 
sda despite unchecking sda as a disk to install".

I can confirm the exact same problem occurred during installing FC7 to an 
external USB 2.0 drive. During installation (based on the custom partitioning 
option), I unchecked sda and also selected the option for not installing 
bootloader. Basically, I did not want the FC7 installer to install *any* 
bootloader. When the installer went to the next step, I noticed that it had 
automatically selected sda for installing bootloader again. I unchecked it 
again and that avoided the trouble that the original reporter faced. However, 
I need to verify that my laptop still boots to MS windows!
Comment 2 Martin Sivák 2007-09-21 03:00:45 EDT
There is a new warning when "What drive would you like to boot this installation
from?" is set to disallowed drive now in rawhide and the bug considering this
combobox is fixed also. (see #243556).

Note You need to log in before you can comment on or make changes to this bug.