Bug 243810 - add Japanese Ruby support (make extension part of default build)
Summary: add Japanese Ruby support (make extension part of default build)
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL: https://addons.mozilla.org/en-US/fire...
Whiteboard: FF3RawhideClose
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-12 00:45 UTC by Eido Inoue
Modified: 2018-04-11 12:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 16:47:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test XHTML code (ASCII) to see if Ruby is working. (531 bytes, text/html)
2007-06-12 00:45 UTC, Eido Inoue
no flags Details

Description Eido Inoue 2007-06-12 00:45:12 UTC
Description of problem:
1. Ruby is a W3C standard.
<http://www.w3.org/TR/ruby/>

2. Ruby is part of the XHTML 1.1 standard.
<http://www.w3.org/TR/xhtml11/changes.html#a_changes>

5. A mozilla add-on exists for both Firefox and Seamonkey which is stable.
<https://addons.mozilla.org/en-US/firefox/addon/1935>

3. Ruby is supported in IE:
<http://msdn.microsoft.com/library/default.asp?url=/workshop/author/dhtml/reference/objects/ruby.asp>

4. Ruby (aka furigana) is an essential part of Japanese, and could be considered
a I18N requirement. Other applications that deal heavily with text processing,
such as OpenOffice and MS Office, support Ruby (even in English). It is also
used (to a much lesser extent) in other languages, such as Chinese.

6. Some distros are including it in their mozilla/firefox/seamonkey RPMs.

Steps to Reproduce:

Use this XHTML 1.1 test code (ruby-test.xhtml):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head><title>Ruby Test</title></head>
<body>
<p>Japanese often eat fish on vinegared rice, which is called
<ruby xml:lang="ja">
  <rbc class="kanji"><rb>&#x5BFF;</rb><rb>&#x53F8;</rb></rbc>
  <rtc class="reading"><rt>&#x3059;</rt><rt>&#x3057;</rt></rtc>
  <rtc class="annotation"><rt rbspan="2" xml:lang="en">Sushi</rt></rtc>
</ruby>
in Japanese.</p>
</body>
</html>
  
Actual results:
Everything on one line.

Expected results:
The reading should be above the kanji, and the annotation should be below the kanji.

Additional info:

Comment 1 Eido Inoue 2007-06-12 00:45:12 UTC
Created attachment 156771 [details]
Test XHTML code (ASCII) to see if Ruby is working.

Comment 3 Matěj Cepl 2007-12-20 16:47:22 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.