Bug 243832 - perl & mod_perl-devel : buggy dependency ?
perl & mod_perl-devel : buggy dependency ?
Status: CLOSED DUPLICATE of bug 228429
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On: 228429
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 05:27 EDT by VnPenguin
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 11:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description VnPenguin 2007-06-12 05:27:22 EDT
Description of problem:

mod_perl-devel is a dependency of perl

Version-Release number of selected component (if applicable):

perl-5.8.8-18.fc7
mod_perl-devel.i386 2.0.3-7

How reproducible:

yum deplist perl

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Have to install mod_perl-devel and a lot of unwanted *-devel package for Perl.
This is definitively unwanted.

Expected results:

mod_perl-devel is NOT needed for standard Perl !!!

Additional info:
Comment 1 Paul Howarth 2007-06-12 06:25:10 EDT
The bug here is in mod_perl, which should not "provide" perl(warnings)
Comment 2 Matěj Cepl 2007-06-12 09:01:13 EDT
Cannot reproduce here with FC7 (x86_64ú:

[matej@hubmaier ~]$ rpm -qa mod_per\*
[matej@hubmaier ~]$ rpm -q perl
perl-5.8.8-18.fc7
[matej@hubmaier ~]$ 

and 

[matej@hubmaier ~]$ sudo yum deplist perl |grep -C 3 mod_perl
  dependency: perl(warnings)
   provider: perl.i386 4:5.8.8-18.fc7
   provider: perl.x86_64 4:5.8.8-18.fc7
   provider: mod_perl-devel.x86_64 2.0.3-7
   provider: mod_perl-devel.i386 2.0.3-7
  dependency: perl(Pod::Usage)
   provider: perl.i386 4:5.8.8-18.fc7
   provider: perl.x86_64 4:5.8.8-18.fc7
--
  dependency: perl(warnings)
   provider: perl.i386 4:5.8.8-18.fc7
   provider: perl.x86_64 4:5.8.8-18.fc7
   provider: mod_perl-devel.x86_64 2.0.3-7
   provider: mod_perl-devel.i386 2.0.3-7
  dependency: perl(Pod::Usage)
   provider: perl.i386 4:5.8.8-18.fc7
   provider: perl.x86_64 4:5.8.8-18.fc7
[matej@hubmaier ~]$ 

which means IMHO that this dependency will be preferably satisfied by perl
package itself.
Comment 3 Paul Howarth 2007-06-12 09:22:52 EDT
(In reply to comment #2)
> Cannot reproduce here with FC7 (x86_64ú:
> 
> [matej@hubmaier ~]$ rpm -qa mod_per\*
> [matej@hubmaier ~]$ rpm -q perl
> perl-5.8.8-18.fc7
> [matej@hubmaier ~]$ 
> 
> and 
> 
> [matej@hubmaier ~]$ sudo yum deplist perl |grep -C 3 mod_perl
>   dependency: perl(warnings)
>    provider: perl.i386 4:5.8.8-18.fc7
>    provider: perl.x86_64 4:5.8.8-18.fc7
>    provider: mod_perl-devel.x86_64 2.0.3-7
>    provider: mod_perl-devel.i386 2.0.3-7
>   dependency: perl(Pod::Usage)
>    provider: perl.i386 4:5.8.8-18.fc7
>    provider: perl.x86_64 4:5.8.8-18.fc7
> --
>   dependency: perl(warnings)
>    provider: perl.i386 4:5.8.8-18.fc7
>    provider: perl.x86_64 4:5.8.8-18.fc7
>    provider: mod_perl-devel.x86_64 2.0.3-7
>    provider: mod_perl-devel.i386 2.0.3-7
>   dependency: perl(Pod::Usage)
>    provider: perl.i386 4:5.8.8-18.fc7
>    provider: perl.x86_64 4:5.8.8-18.fc7
> [matej@hubmaier ~]$ 
> 
> which means IMHO that this dependency will be preferably satisfied by perl
> package itself.

In theory that is correct, and traditional yum behaviour has always been to
choose the package with the shortest name in the event of multiple packages
providing a dependency, hence perl would be preferred to mod_perl-devel.

However, there have been many reports of packages with longer names being
selected in F7, and this would appear to be an instance of this.

It could probably be worked around by doing:
# yum --exclude=mod_perl-devel install perl

but surely nobody would deny that having mod_perl-devel provide perl(warnings)
is a bug?
Comment 4 Tom "spot" Callaway 2007-06-12 09:36:30 EDT
Yes, I'm sure that having mod_perl-devel provide perl(warnings) is a bug.
Comment 5 Chris Weyl 2007-06-12 10:53:23 EDT
I filed a bug against mod_perl providing perl(warnings) a while ago; it was
marked closed/rawhide:  bug 228429.  I'm reopening.
Comment 6 Chris Weyl 2007-06-12 11:09:36 EDT
mod_perl-devel no longer provides perl(warnings) as of 2.0.3-9.  

(/me reminds himself to update before tinkering with closed bugs...)
Comment 7 Joe Orton 2007-06-18 11:49:07 EDT

*** This bug has been marked as a duplicate of 228429 ***

Note You need to log in before you can comment on or make changes to this bug.