Bug 243848 - iperf perfoms bad with F7 kernel
Summary: iperf perfoms bad with F7 kernel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-12 12:05 UTC by Michal Žejdl
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 08:22:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Žejdl 2007-06-12 12:05:56 UTC
Description of problem:
Running iperf on 100 Mbps NIC slow down system response, resulting in bad
transfer ratio (3 - 15 Mbps) in download direction, or in both direction when
"vmstat 1" is runnig. This appears since F7.

Version-Release number of selected component (if applicable):
2.6.21-1.3194.fc7

How reproducible:
always

Steps to Reproduce:
1. run vmstat 1 to make worst performance results and see what happens
2. run iperf -s on remote machine
3. run iperf -c <remote machine> -r
  
Actual results:
[  5] local 10.1.224.176 port 56235 connected with 10.1.3.77 port 5001
[  5]  0.0-10.0 sec    113 MBytes  94.5 Mbits/sec
[  4] local 10.1.224.176 port 5001 connected with 10.1.3.77 port 50328
[  4]  0.0-10.1 sec  17.0 MBytes  14.1 Mbits/sec
- vmstat shows 100% cpu used (over 90% in syscalls), system has a slow response

Expected results:
94 Mbps in both directions (iperf), more interrupts and less system time on CPU
(vmstat), normal system response

Additional info:
System with problem is laptop Acer TravelMate 290LCi with updated Fedora 7,
using 8139too module. With kernel 2.6.20-1.2952.fc6 there is no problem.


Note You need to log in before you can comment on or make changes to this bug.