Bug 243872 - fence_xvmd doesn't reboot VM
fence_xvmd doesn't reboot VM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 10:30 EDT by Christine Caulfield
Modified: 2009-04-16 18:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0575
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:59:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virtual machine config (7.18 KB, application/octet-stream)
2007-06-25 10:24 EDT, Lon Hohberger
no flags Details
Allows hvm rebooting (9.55 KB, patch)
2007-06-26 13:15 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Christine Caulfield 2007-06-12 10:30:36 EDT
Description of problem:
Using fence_xvmd for fencing in a VM cluster. the VM is shut down rather than
rebooted. Needing a manual restart.

Version-Release number of selected component (if applicable):
Current RHEL5 CVS as of 12th June 2007

How reproducible:
Always

Steps to Reproduce:
1. run fence_xvmd -d -f on dom0
2. startup a cluster of VMs
3. fence one of them, eg
   fence-xvm -H pjc-xen-02
  
Actual results:
The VM disappears from the VM list and has to be restarted manually

Expected results:
The VM should reboot

Additional info:
I get the following error reported by fence_xvmd on the dom0:

Calling virDomainCreateLinux()...
libvir: error : missing operating system information for pjc-xen-06
libvir: Xen Daemon error : XML description for Failed to parse the XML domain d
scription is not well formed or invalid
Comment 1 RHEL Product and Program Management 2007-06-12 11:45:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Lon Hohberger 2007-06-25 10:00:48 EDT
Patrick, can we get:

* virsh dumpxml (while running) (I think we had this from fence_xvmd; I'll look
at IRC logs)

* original domain config
Comment 3 Lon Hohberger 2007-06-25 10:04:47 EDT
Rebooting domain pjc-xen-06...
[[ XML Domain Info ]]
<domain type='xen' id='696'>
  <name>pjc-xen-06</name>
  <uuid>fcdd2236ddc18c800b62380548265822</uuid>
  <os>
    <type>hvm</type>
    <loader>/usr/lib/xen/boot/hvmloader</loader>
  </os>
  <memory>524288</memory>
  <vcpu>1</vcpu>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <features>
    <pae/>
  </features>
  <devices>
    <emulator>/usr/lib/xen/bin/qemu-dm</emulator>
    <interface type='bridge'>
      <source bridge='xenbr0'/>
      <mac address='02:10:15:84:04:06'/>
      <script path='vif-bridge'/>
    </interface>
    <disk type='file' device='disk'>
      <driver name='file'/>
      <source file='/root/pjc6'/>
      <target dev='hda'/>
    </disk>
    <graphics type='vnc' port='5900'/>
    <console tty='/dev/pts/0'/>
  </devices>
</domain>
 
[[ XML END ]]
Clearing 82 bytes starting @ 0x916e2f9
[[ XML Domain Info (modified) ]]
<domain type='xen' id='696'>
  <name>pjc-xen-06</name>
  <uuid>fcdd2236ddc18c800b62380548265822</uuid>
                                                                                   
  <memory>524288</memory>
  <vcpu>1</vcpu>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <features>
    <pae/>
  </features>
  <devices>
    <emulator>/usr/lib/xen/bin/qemu-dm</emulator>
    <interface type='bridge'>
      <source bridge='xenbr0'/>
      <mac address='02:10:15:84:04:06'/>
      <script path='vif-bridge'/>
    </interface>
    <disk type='file' device='disk'>
      <driver name='file'/>
      <source file='/root/pjc6'/>
      <target dev='hda'/>
    </disk>
    <graphics type='vnc' port='5900'/>
    <console tty='/dev/pts/0'/>
  </devices>
</domain>
 
[[ XML END ]]
[REBOOT] Calling virDomainDestroy
Calling virDomainCreateLinux()...
libvir: error : missing operating system information for pjc-xen-06
libvir: Xen Daemon error : XML description for Failed to parse the XML domain
description is not well formed or invalid
Sending response to caller...


Feeding in the *unaltered* XML to virDomainCreateLinux(), we get:

libvir: Xen Daemon error : POST operation failed: (xend.err 'Error creating
domain: int argument required')
Comment 4 Lon Hohberger 2007-06-25 10:17:43 EDT
If possible, libvirt + xen RPM versions might be helpful, I think, too.
Comment 5 Lon Hohberger 2007-06-25 10:22:55 EDT
[root@bid-04 xen]# rpm -q xen libvirt
xen-3.0.3-25.el5
libvirt-0.1.8-15.el5
Comment 6 Lon Hohberger 2007-06-25 10:24:37 EDT
Created attachment 157757 [details]
virtual machine config
Comment 7 Lon Hohberger 2007-06-25 10:33:23 EDT
Ok, we need to flip the port to '-1' for the graphics block.

Also, for full-virt instances, we need to *not* kill the <os> block.
Comment 9 Lon Hohberger 2007-06-26 13:15:12 EDT
Created attachment 157918 [details]
Allows hvm rebooting
Comment 10 Lon Hohberger 2007-06-26 13:16:08 EDT
I regression-tested this on a 5-node rhel5 cluster w/ paravirt rhel5 guests as
well as a single-node full-virt setup.
Comment 11 Christine Caulfield 2007-06-27 03:35:14 EDT
Works for me :-)
Comment 14 errata-xmlrpc 2007-11-07 11:59:39 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0575.html

Note You need to log in before you can comment on or make changes to this bug.