Bug 243900 - kernel panic with raid 1
kernel panic with raid 1
Status: CLOSED DUPLICATE of bug 241949
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 13:00 EDT by mark
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 16:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
initrd-2.6.21-1.3194.fc7.img (2.65 MB, application/octet-stream)
2007-06-15 22:29 EDT, mark
no flags Details

  None (edit)
Description mark 2007-06-12 13:00:29 EDT
just upgraded from fc6 to f7 using the dvd method. my computer has 2 SATA drives
and is partitoned like so:

/dev/sda1 linux partition
/dev/sda2 linux swap

/dev/sdb1 linux partition

It should be noted that sda1 and sda2 are using RAID 1 at /dev/md0. After
installing, I tried booting and got the follow kernel panic:

Creating root device.
mkrootdev: expected fs options
mounting root filesystemb.
mount: missing mount point
setting up other filesystems.
setting up new root fs
setuproot: moving /dev failed: no such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: no such file or directory
setuproot: error mounting /sys: no such file or directory
switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: no such file or directory
Booting has failed.
kernel panic - not syncing: Attempted to kill init!

grub.conf
-----------
root (hd0,0)
kernel /boot/vmlinuz-version root=/dev/md0
initrd /boot/initrd-version.img

It should also be noted that my /dev/md0 has only a single mount point "/" (i.e.
no separate /boot mount points etc.)

Let me know what else you need to help resolve this issue.

mark.
Comment 1 mark 2007-06-15 12:06:03 EDT
I created a /boot partition in sdb2 (formerly free space) and then reinstalled
the kernel but the problem still exists. I'll try and post my /etc/fstab later
tonight.
Comment 2 Chuck Ebbert 2007-06-15 13:52:32 EDT
Please post contents of /etc/fstab and also create an attachment with the
contents of your initrd.
Comment 3 mark 2007-06-15 22:29:43 EDT
Created attachment 157172 [details]
initrd-2.6.21-1.3194.fc7.img
Comment 4 mark 2007-06-15 22:34:45 EDT
/dev/sdb2		/boot			ext3	defaults	1 1
/dev/md0                /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-sda2         swap                    swap    defaults        0 0
Comment 5 mark 2007-06-21 16:06:03 EDT

*** This bug has been marked as a duplicate of 241949 ***

Note You need to log in before you can comment on or make changes to this bug.