Bug 243905 - X Crashes When Switching Virtual Terminals And Using Rhythmbox
X Crashes When Switching Virtual Terminals And Using Rhythmbox
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 13:22 EDT by Devan Goodwin
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 12:05:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2007-06-12 13:22:07 EDT
Switching to the console (Ctrl+Alt+F1) and back again (Alt+F7) while Rhythmbox
is playing will result in your X session crashing and disappearing, after which
gdm promptly creates a new login screen.

1. Login to X.
2. Start Rhythmbox and ensure it's actually playing music. (or paused, more on
this later)
3. Switch to console (Ctrl+Alt+F1)
4. Switch back (Alt+F7)
  
X will at this point go down with the following stack trace being printed to logs:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x6d) [0x47f5ed]
1: /lib64/libc.so.6 [0x38fa030620]
2: /usr/bin/Xorg [0x48eb91]
3: /usr/bin/Xorg [0x48f055]
4: /usr/bin/Xorg(TraverseTree+0x33) [0x4361b3]
5: /usr/bin/Xorg [0x48f0d0]
6: /usr/bin/Xorg(xf86Wakeup+0x3ea) [0x480a7a]
7: /usr/bin/Xorg(WakeupHandler+0x51) [0x44f101]
8: /usr/bin/Xorg(WaitForSomething+0x1d4) [0x565184]
9: /usr/bin/Xorg(Dispatch+0x9a) [0x44b19a]
10: /usr/bin/Xorg(main+0x45d) [0x43404d]
11: /lib64/libc.so.6(__libc_start_main+0xf4) [0x38fa01daa4]
12: /usr/bin/Xorg(FontFileCompleteXLFD+0x231) [0x433319]

Fatal server error:
Caught signal 11.  Server aborting

Originally this was thought to be due to the proprietary nvidia driver and it
took some time to isolate Rhythmbox as the determining factor in the crash.
However once this was discovered I can now replicate the crash 100% of the time
using the nv driver as well. I cannot test other video drivers as I have none at
my disposal, but given that it 's unlikely to be a hardware problem (I've used
this functionality for years on this hardware) I'm under the assumption that the
video driver doesn't really matter.

Problem is also apparent when switching to another X session (via user switcher
applet where the problem first surfaced, or spawning a new gdm session and
switching back and forth with Ctrl+Alt+F9 etc).

The problem appears to be specific to Rhythmbox and not sound in general, the
crash does not seem to occur with Totem or vlc playing.

Also, Rhythmbox must be playing or paused:
- Open Rhythmbox but play nothing = no crash
- Open Rhythmbox, play something = crash
- Open Rhythmbox, play something, pause = crash
- Open Rhythmbox, play something, close Rhythmbox = no crash
Comment 1 George Billios 2007-06-13 01:40:22 EDT
I can also reproduce the problem using the fast user switch applet or using the
keyboard shortcuts to change console in FC7. 

Comment 2 Dominik Sandjaja 2007-06-13 12:31:02 EDT
Also reproducible on a non-64 bit system (i686), also Fedora 7.
Comment 3 Devan Goodwin 2007-06-13 13:13:54 EDT
Forgot to mention, my system is x86_64.
Comment 4 Devan Goodwin 2007-06-17 11:49:23 EDT
Recent updates (xorg as well as several x drivers) seem to have taken care of
this problem. I can no longer replicate the crash with Rhythmbox playing, just
notice a very brief interruption in sound but everything works fine.
Comment 5 George Billios 2007-06-17 13:23:01 EDT
I can also confirm that this bug seems resolved using the latest
xorg-x11-server-Xorg for f7. 

Note You need to log in before you can comment on or make changes to this bug.