Bug 243928 - console keymap not loaded correcly in Unicode (UTF-8) locales
Summary: console keymap not loaded correcly in Unicode (UTF-8) locales
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kbd (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Vitezslav Crhonek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-12 19:51 UTC by Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail}
Modified: 2010-03-18 15:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-18 15:58:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed (see the last paragraphs of description) fix (594 bytes, patch)
2007-06-12 19:51 UTC, Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail}
no flags Details | Diff

Description Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2007-06-12 19:51:10 UTC
Description of problem:

When a Unicode (UTF-8 actually) locale is being used (which seems to be the
default) a non-US keymaps don't work.

Note: This is similar (inverse, actually) to bug 167363 but applies in RHEL 4
(actually tested on CentOS 4, but the initscripts package is quite the same --
the CentOS modifications are minimal and should cause no difference in this regard).


Version-Release number of selected component (if applicable):

7.93.29.EL-1 (actually 7.93.29.EL-1.centos4)


How reproducible:

Always.


Steps to Reproduce:

1. Use a non-English locale with UTF-8 encoding (I used cs_CZ.UTF-8) and an
appropriate keyboard layout (keymap).
2. When logged in on the console(!), try to write some text containing the
national characters.
3. Watch some strange and unexpected characters display in the typed text.

  
Actual results:

When typing any national characters, strange characters are displayed (and in
fact, also entered).


Expected results:

The exact characters typed should be entered and appear.


Additional info:

This is apparently a known problem (see 150769, comment 26). According to this
comment (plus others in that bug) and the `initscripts' package changelog there
was already a fix available which was later reverted because it provoked the bug
143124. (Can someone confirm or deny this "theory"?)

The bug 143124 mentions two methods of correction (see bug 143124, comment 4 and
bug 143124, comment 5). This bug , however, referse to FC and so do probably any
fixes made. Will there be any further/related solution for RHEL 4?

A tested patch against `initscripts' is available (this is what I'm using at the
moment) and attached. Since this may "summon" the bug 143124, it is provided
rather for reference and for those who don't have problems with kbd and want
Unicode to work on the console. (The patch is actually a minimal part of the
patch from the bug 150769).

For the very same reason, this bug might have to be refiled against the `kbd'
package, but the most apparent culprit is `inistscripts' which I'm currently
filing against.

Comment 1 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2007-06-12 19:51:10 UTC
Created attachment 156823 [details]
proposed (see the last paragraphs of description) fix

Comment 2 Bill Nottingham 2007-06-12 20:21:31 UTC
kbd needs fixed first.

Comment 3 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2007-06-12 20:44:37 UTC
Re-file against kbd then?


Comment 4 Bill Nottingham 2007-06-12 20:52:37 UTC
Just reassigning it works.

Comment 5 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2007-06-12 21:12:56 UTC
That's what I meant. :-)

And as I can see in the `bug activity' now, you already did so but I reverted
it. Sorry for that. Probably didn't force full reload of the bug in my browser.

Must have been sitting here too long now. :-(


Comment 6 Ondrej Vasik 2010-03-18 15:58:07 UTC
As RHEL-4.9 is last update for RHEL-4 and it is not suitable for new features
and should address only security, performance and critical issues, I'm closing
that bugzilla WONTFIX. If this functionality is still missing in RHEL-5, feel
free to clone that bugzilla against it.


Note You need to log in before you can comment on or make changes to this bug.