Bug 243930 - Translation files exist, but are not being used
Translation files exist, but are not being used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
5
All Linux
low Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 15:58 EDT by Lauri Nurmi
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.13-0.52.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 16:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lauri Nurmi 2007-06-12 15:58:03 EDT
Description of problem:

Applications of the util-linux package are looking for their translated messages
in a completely wrong location.

Version-Release number of selected component (if applicable):

Any version of util-linux in at least FC5, FC6 or F7.

How reproducible:

Every time.

Steps to Reproduce:
1. Set your locale to e.g. fi_FI.UTF-8, or any other language to which
util-linux has been translated.
2. Run e.g. `hwclock --help' or `fdisk --help'
  
Actual results:
The help text is shown in English.

Expected results:
Seeing the help text in Finnish (or whatever was chosen as language above).

Additional info:

The translation files exist in the util-linux RPM, and they also contain the
appropriate messages, but for some reason the applications are searching the
files in the wrong path.

Debugging the situation with `strace' reveals:
# strace hwclock --help 2>&1 | grep LC_MESSAGES
open("/share/locale/fi_FI.UTF-8/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/share/locale/fi_FI.utf8/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/share/locale/fi_FI/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
open("/share/locale/fi.UTF-8/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/share/locale/fi.utf8/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/share/locale/fi/LC_MESSAGES/util-linux.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)

Notice the path is /share, not /usr/share.

On FC6, the path begins e.g. with /root//fi_FI.UTF-8/..., and on FC5, an even
more surprising path /tmp//fi_FI.UTF-8/... is used.
Comment 1 Karel Zak 2007-06-12 17:41:34 EDT
This problem has been fixed in upstream code. I'll backport it to FC6 and FC7.
Thanks.
Comment 2 Lauri Nurmi 2007-06-27 07:01:04 EDT
Since FC5 is still within support for a few days, could we get an updated
util-linux package for FC5 as well, please?
Comment 3 Fedora Update System 2007-07-11 11:17:01 EDT
util-linux-2.13-0.52.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-07-18 16:57:25 EDT
util-linux-2.13-0.52.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.