Bug 243944 - pirut/yum are not working after upgrading from Fedora 6 to fedora 7
pirut/yum are not working after upgrading from Fedora 6 to fedora 7
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 17:27 EDT by EZ
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 18:00:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Both commands messages output (8.61 KB, text/plain)
2007-06-12 17:27 EDT, EZ
no flags Details

  None (edit)
Description EZ 2007-06-12 17:27:41 EDT
Description of problem:
I upgraded from F6 to F7, unfortunately I'm unable to run pirut (Software
Manager)  or manually yum. the problem seems in python modules.

Version-Release number of selected component (if applicable):
pirut - 1.3.7-1.fc7.noarch
yum-metadata-parser - 1.1.0-2.fc7
yum - 3.2.0-1.fc7.noarch

How reproducible:
just run pirut or yum

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
see attachment

Expected results:
pirut, yum should run normally and able to update the packages.

Additional info:
There were some warning during upgrade and are listed here (for information only):

Upgrading nautilus-sendto - 0.10-4.fc7.i386
I/O warning : failed to load external entity "/etc/gconf/schemas/nst.schemas"
Failed to open `/etc/gconf/schemas/nst.schemas': No such file or directory

Upgrading gnome-games - 1:2.18.1.1-1.fc7.i386
I/O warning : failed to load external entity "glchess.schemas"
Failed to open `glchess.schemas': No such file or directory

Upgrading control-center - 1:2.18.0-18.fc7.i386
I/O warning : failed to load external entity
"/etc/gconf/schemas/control-center.schemas"
Failed to open `/etc/gconf/schemas/control-center.schemas': No such file or
directory
Comment 1 EZ 2007-06-12 17:27:41 EDT
Created attachment 156831 [details]
Both commands messages output
Comment 2 Gianluca Varisco 2007-06-13 05:30:07 EDT
Thank you for taking the time to report this bug. The "biosHdr" python module is
available into this package: firmware-addon-dell.

/usr/lib/python2.5/site-packages/biosHdr.py
/usr/lib/python2.5/site-packages/biosHdr.pyc
/usr/lib/python2.5/site-packages/biosHdr.pyo

This is the yum output regarding "yum install firmware-addon-dell":

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
firmware-addon-dell     i386       1.2.13-1.fc7     fedora             26 k
Installing for dependencies:
firmware-tools          noarch     1.2.4-1.fc7      fedora            101 k
libsmbios-bin           i386       0.13.6-1.fc7     fedora             57 k

You can try to install manually these packages by downloading from
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Everything/i386/os/Fedora/


However, the error that both yum and pirut noticed seems a bit strange to me (I
don't have these packages installed and both work fine for me).

While Waiting an answer from Jeremy Katz, you can try to do what I wrote above.
Comment 3 Jeremy Katz 2007-06-13 14:43:00 EDT
Doing an update of the plugin package (by running 'yum --noplugins update yum*')
should help things out.  I've posted a patch upstream to potentially just bail
out and not die like this when plugins fail to load for the future
Comment 4 EZ 2007-06-13 17:53:27 EDT
Thanks for replying to my post, I installed the packages manually from the link
mentioned above and things went fine; however, before I downloaded them I tried
to find the package firmware-addon-dell from Fedora 7 distribution CD (dvd) and
I found that the package was not there, this seems to lead to the mean issue
which is the package firmware-addon-dell was not included in the distribution CD
(Here I'm talking about the DVD iso).

Thanks and appreciate your support.

 
Comment 5 Jeremy Katz 2007-06-13 18:00:58 EDT
Yes, all of the packages in the Fedora universe wouldn't fit on one DVD (in
fact, would barely fit on two currently!) so some things will still have to be
updated from the net after doing the distro ugprade.

Better handling for the plugin failure is going on upstream and help out; thanks
for the report!

Note You need to log in before you can comment on or make changes to this bug.