Bug 243977 - NetworkManager won't quit second time (prevents suspend/resume more than once)
Summary: NetworkManager won't quit second time (prevents suspend/resume more than once)
Status: CLOSED DUPLICATE of bug 241783
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 06:16 UTC by David Baron
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 20:31:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f -F of successful (first) /sbin/service NetworkManager stop (109.66 KB, text/plain; charset=UTF-8)
2007-06-13 18:51 UTC, David Baron
no flags Details
strace -f -F of failed (second) /sbin/service NetworkManager stop (114.02 KB, text/plain; charset=UTF-8)
2007-06-13 18:52 UTC, David Baron
no flags Details

Description David Baron 2007-06-13 06:16:40 UTC
Description of problem:  Restarting network manager succeeds once, but the
second time NetworkManager doesn't quit (doesn't even respond to kill -9).  This
means I can't suspend my laptop more than once without rebooting, since each
suspend-resume cycle restarts NetworkManager.

Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-3.fc7
kernel-2.6.21-1.3194.fc7

How reproducible: Always

Steps to Reproduce:
1. /sbin/service NetworkManager stop
2. /sbin/service NetworkManager start
3. /sbin/service NetworkManager stop
  
Actual results:
root@ridley Linux (0) ~ # /sbin/service NetworkManager stop
Stopping NetworkManager daemon:                            [  OK  ]
root@ridley Linux (0) ~ # /sbin/service NetworkManager start
Setting network parameters... 
Starting NetworkManager daemon:                            [  OK  ]
root@ridley Linux (0) ~ # /sbin/service NetworkManager stop
Stopping NetworkManager daemon:                            [FAILED]
root@ridley Linux (1) ~ # ps auwwx | grep NetworkManager
root      2380  0.0  0.0   3268  1044 ?        Ss   22:35   0:00
NetworkManagerDispatcher
--pid-file=/var/run/NetworkManager/NetworkManagerDispatcher.pid
root      5243  0.1  0.1  24924  2004 ?        Rs   23:02   0:00 NetworkManager
--pid-file=/var/run/NetworkManager/NetworkManager.pid
root      5275  0.0  0.0   4016   736 pts/1    R+   23:02   0:00 grep NetworkManager
root@ridley Linux (0) ~ # kill -9 5243
root@ridley Linux (0) ~ # kill -9 5243
root@ridley Linux (0) ~ # kill -9 5243


Expected results: NetworkManager can be stopped and started indefinitely.


Additional info:
Once NetworkManager is wedged, other programs, such as postfix, are also unable
to quit.

I'm using NetworkManager for wireless connections over my ipw2200.  My wired
ethernet is an e1000.

Comment 1 David Baron 2007-06-13 18:51:44 UTC
Created attachment 156899 [details]
strace -f -F of successful (first) /sbin/service NetworkManager stop

Comment 2 David Baron 2007-06-13 18:52:26 UTC
Created attachment 156900 [details]
strace -f -F of failed (second) /sbin/service NetworkManager stop

Comment 3 Christopher Aillon 2007-06-13 19:05:53 UTC
This is probably another side effect of the e1000 bug in the FC7 kernel. 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=241783

Comment 4 David Baron 2007-06-13 20:31:25 UTC
Yep, adding "install e1000 /bin/true" to /etc/modprobe.conf fixes the problem.

*** This bug has been marked as a duplicate of 241783 ***


Note You need to log in before you can comment on or make changes to this bug.