Bug 244 - Xconfigurator attempts to use SVGA server with S3 virge card
Xconfigurator attempts to use SVGA server with S3 virge card
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-30 20:33 EST by dastardly
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-09 16:09:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dastardly 1998-11-30 20:33:29 EST
Xconfigurator freezes during the autoprobe section where the
screen blinks.  This does not happen with the same hardware
in RH5.1.  In RH5.1 Xconfigurator detects an S3 Virge/VX
card and attempts to use the S3-Virge server.  RH5.2
Xconfigurator detects S3 Virge/VX but instead tries to use
the SVGA server.  My video card is an STB Velocity-3D.

I got around the problem by installing RH5.1 then upgrading
to 5.2.  Thereby causing the Xconfigurator step to be
skipped and the RH5.1 settings used.

Don Wellington
Comment 1 Jay Turner 1998-12-09 11:57:59 EST
Is this card a PCI card?  If it is not then the autoprobe step will
indeed hang, and this might be the problem that you are seeing.
Comment 2 dastardly 1998-12-09 12:39:59 EST
It is a PCI card.  As I said before, it appears to me that the routine
that decides what X-server to use broke between RH5.1 and RH5.2
because the S3 Virge/VX server should be used not the svga server.
RH5.1 handles it correctly RH5.2 doesn't.
Comment 3 David Lawrence 1998-12-09 16:09:59 EST
The installtion  code for 5.2 is actually supposed to be picking the
SVGA server for the S3V chips.  However is this is not working for
you, install the S3V server rpm and modify the /etc/X11/X symbolic
link to point to the S3V server rather than the SVGA server.

Note You need to log in before you can comment on or make changes to this bug.