This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 244017 - xchat tray notification is turned off by default for no obvious reason.
xchat tray notification is turned off by default for no obvious reason.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 08:30 EDT by Rudolf Kastl
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 15:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2007-06-13 08:30:14 EDT
Description of problem:
actually the xchat tray notification is beeing patched off for not obvious
reason. other irc messaging solutions we ship do have tray notification on by
default (pidgin, xchat-gnome) so i am curious why upstreams behaviour is beeing
changed for especially xchat.

Maybe it would be worth discussing that issue on the mailinglist but since the
issue was reported as regression and then patched i am curious what is buggy
about it.

Version-Release number of selected component (if applicable):
xchat-2.8.2-9
Comment 1 Kevin Kofler 2007-06-13 08:33:25 EDT
CCing Matthias Clasen because he requested this change in the first place.
Comment 2 Matthias Clasen 2007-06-13 12:45:18 EDT
Well, Fedora is not just about shipping whatever configuration upstream happens
to prefer for whatever reason. We are trying to ship defaults that make sense
and give an integrated coherent appearance. If every running application puts a
status icon in the notification area, we can just as well have no notification
area and just put a second window list there...
Comment 3 Christopher Aillon 2007-06-13 13:22:24 EDT
The notification area should be used only for notifications, not to say "I'm
running".  If other applications are abusing that, they should get bugs filed too.

Okay: your xchat window does not have focus but someone speaks to you.  A
notification icon appears.  You click on it, and it brings xchat to focus,
possibly switching to the channel tab where the person was talking to you, and
then the notification icon dissapears.

NOT Okay: notification icon is on all the time.

Additionally, xchat has another way of alerting the user already.  The item in
the window list blinks.
Comment 4 Rudolf Kastl 2007-06-13 13:58:34 EDT
alright other messaging applications that need patches then from your point of view:

pidgin
xchat-gnome
ekiga

other applications that show permanently:

bluetooth
nm-applet (should by definition probably be a panel applet)
gnome-power-manger (should by definition also be a panel applet)

just to name those i know from top of my head

the window show/hide functionality alot people like about it will be lost then
aswell by default. while i know what is defined as use case for the notification
area i am really curious how users see that from their point of view. for me as
a user it is simply convenient for those kind of applications and it enhances
the desktop experiences as well makes the whole deal feel more integrated.

i am really curious if this is the right road though and i really think this
should be discussed further on the mailinglists.

what do you think?

thanks for not just closing this bug and give me time to respond.
Comment 5 Matthias Clasen 2007-06-13 14:05:09 EDT
Wrt to your list: bluetooth and g-p-m have configuration for this, and I hope we
default for them to only be shown when there is status to report.

I don't see much good coming out of a discussion on the mailing list, tbh
Comment 6 Christopher Aillon 2007-06-13 14:15:22 EDT
Looks like gaim also has a configuration to only show on unread messages.  We
should fix the default for that, too.
Comment 7 Rudolf Kastl 2007-06-13 14:23:52 EDT
well what we would get is actual user feedback about integration and usability.

while i personally also hate discussions and while i dont think the "majority is
right" unfortunately i just dont share opinion on the matter. 

while i can see your point of view clearly i am not sure if you can see mine on
the matter at hand.

if so many developers / applications /people (with their settings) abuse the
notification area for things and behaviour like that i would (and do) ask myself
why it happens the way it does...

i bet everyone knows what is supposed to be in the tray... so there actually
must be something missing yet the area is used as substitute for.

comparing it with the windowlist is not that wrong in my eyes theres just one
big difference. those applications showing in tray are usually the perma running
ones...

you want em available on any desktop... you want their status be visible and see
if you are connected and see at one spot if everything is running...

you dont want to clutter those applications up the windowlist because there you
have your non perma running applications you are really working with.

now as far as integration goes this problem should be tackled and then the abuse
of the notification area will stop. it wont be abused or "misused" by users or
developers anymore.

especially if it works (like the tray notification) with most of todays shipped
windowmanager/panels/desktops.

until this problem is tackled the "abuse" will go on no matter how the defaults
are set... theres just other functionality missing yet that covers the behaviour
users want.

i am curious if you would go as far as agreeing on that with me.

Comment 8 Rudolf Kastl 2007-06-13 15:06:16 EDT
since theres no more point in discussing that anymore after some attempts i am
giving up and closing that bug.

i am really curious if all those abusing applications will really be fixed till
fc8 and the nm applet which also abuses the tray will be rewritten.

my resolution: i will build my own packages.

thanks for your time.
Comment 9 Christopher Aillon 2007-06-13 15:29:24 EDT
(In reply to comment #7)
> well what we would get is actual user feedback about integration and usability

Not if you ask them "do you expect A or B".  The only way to get proper user
feedback is to do usability lab testing of various types of users, from beginner
to expert and give them a task such as "Browse the web.  When you get an IM,
respond to them" and see how they react.
Comment 10 Rudolf Kastl 2007-06-13 15:37:13 EDT
its as simple as if i have to do 3 clicks more to change online status it
doesent increase useability for me for such a common task.

if you let it do 20 people and if you look at the default use cases for an im
application like pidgin you most probably wont get a different result.

but i would be really happy to see the statistics on the matter.

removing the abuse doesent fix the core of the problem i see which is a missing
substitute that solve e.g. the above simple use case and the issues mentioned in #7
Comment 11 Rudolf Kastl 2007-06-13 15:43:07 EDT
#9 again...

i have to disagree to some extent because users used to different behaviour will
always react to what they are used to as opposed to the most efficient way
regarding usability once you got used to new behaviour.

with this kind of test i am pretty sure various changes in gnomes behaviour
especially those that have been screamed about most wouldnt have happened (new
file selection dialog e.g.)

i do like the new file selection dialog but people were used to different
behaviour which is of course a completly different case than just looking at the
most common use cases and have a quick way to achieve them with wasting the
least possible screen/panel space and having the least clicks to get to the goal.

Comment 12 Kevin Kofler 2007-06-13 15:47:35 EDT
Why is what happens to be the default so important to you? This kind of 
differences in user preferences are what preference settings are for, really.
Comment 13 Christopher Aillon 2007-06-13 15:49:54 EDT
Online status is a different thing altogether.  We'd love to hook it in so that
you only have 1 place to change status.  Right now, if someone's using xchat for
IRC, and pidgin for IM, and they prefer to lock their screen when they go away,
etc. they have to mark themselves /away in xchat (does it still require you to
do this for every server you're on?), away in pidgin, and then lock the
computer.  Ideally, you shouldn't have to do this from the clients, there would
be one system way of doing it, and it would mark all your presence based apps as
away/back.
Comment 14 Matthias Clasen 2007-06-13 15:58:39 EDT
To top if off, gnome-screensaver can now show an away message in the lock
dialog, too. Like "Just went to the loo..."
Comment 15 Rudolf Kastl 2007-06-13 16:04:15 EDT
i can just talk about myself in this special case but i definitely have
different status in xchat pidgin and ekiga.

the idea to have one keypress for beeing away from screen etc is a nice idea but
it still is no complete substitute for the current functionality and the window
show/hide without cluttering the windowlist.

i hope you understand me right and you get the core of my thoughts and why i
opened this as bug at all. if it was just about default settings id be all set
but what i see is a general lack of functionality / standard that can solve
similar issues without raising the click ratio for common tasks with those
applications unnecasserily.

i do see that like 90% or more of the things in the tray abuse it... and what
happens here is curing the symptom. i thought it is maybe a nice start to get
more discussions and brainstorming going on about this issue. i dont claim that
i know everything or that i have the reciept to cure it and maybe it is the
wrong forum to even get something going for future ideas on how to create the
desktop of the 21st century but i just felt the need to do so now. i just hope
your feeling about this isnt that i am wasting your time with sharing my
opinions and thoughts.

Comment 16 Rudolf Kastl 2007-06-13 16:14:15 EDT
#12 default settings is what i can bear with... also with including and
excluding patches or dealing with other things i want to customize...

my mom cant and wont go into the settings and look for arbitrary checkboxes. she
wont understand what functionality behind "notification area applet always show"
is and her desktop experience will for large parts rely on the defaults.
Comment 17 Rudolf Kastl 2007-06-13 16:33:46 EDT
#14 i have seen that since a while because i am running rawhide. nice
functionality aswell.

Note You need to log in before you can comment on or make changes to this bug.