Bug 244022 - Temporary failure in name resolution: Illegal seek when telneting to RH5
Temporary failure in name resolution: Illegal seek when telneting to RH5
Status: CLOSED DUPLICATE of bug 253392
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: telnet (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 08:50 EDT by Kenneth Hansen
Modified: 2013-04-30 19:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-03 04:49:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Hansen 2007-06-13 08:50:26 EDT
Description of problem:
When trying to telnet to RH5, I recieve: "Temporary failure in name resolution:
Illegal seek" and host disconnects.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Client release 5 (Tikanga)
telnet-server-0.17-38.el5

How reproducible:
Just telnet :)
If you enter the clients IP and name in /etc/hosts or use a DNS server it works
as it should. Seems like a bug that cant handle that reverse lookup cant be done.

I havent checked whether or not the DNS server have to have an A Name record or not 

Steps to Reproduce:
1. Rename /etc/resolv.conf to /etc/resolv.conf.org
2. Remove clients IP and name from /etc/hosts
3. Telnet from client to Server
  
Actual results:


Expected results:


Additional info:
Comment 1 Harald Hoyer 2007-08-01 05:59:17 EDT
starting the telnetd with "-c" should help in this case..
Comment 2 Kenneth Hansen 2007-08-01 17:15:46 EDT
Thank for the reply.

That flag pointed me to Bug 223448 (was curious about what it meant :)

-c           This option disables reverse dns checking. Of course that
              security is lower with this option

I have tried with "server_args = -c" and "server_args = in.telnetd -c" in
/etc/xinetd.d/telnet and restarted xinetd.
when trying to telnet to the server I get:

Trying 192.168.1.109...
Connected to 192.168.1.109.
Escape character is '^]'.
in.telnetd: invalid option -- c
Usage: telnetd [-debug] [-D (options|report|exercise|netdata|ptydata)]
         [-h] [-L login_program] [-n] [port]
Connection closed by foreign host.

Am I doing something wrong? :)
Comment 3 Harald Hoyer 2007-08-02 05:09:42 EDT
$ cat /etc/xinetd.d/telnet
# default: on
# description: The telnet server serves telnet sessions; it uses \
#       unencrypted username/password pairs for authentication.
service telnet
{
        flags           = REUSE
        socket_type     = stream        
        wait            = no
        user            = root
        server          = /usr/sbin/in.telnetd
        server_args     = -c
        log_on_failure  += USERID
        disable         = no
}

works for me
Comment 4 Harald Hoyer 2007-08-02 05:15:36 EDT
ah, oh... different version in RHEL5 without the "-c" patch :-/ sorry...
also see bug #248063
Comment 5 Kenneth Hansen 2007-08-04 19:27:19 EDT
Be happy to, but Bugzilla disagress :)

You are not authorized to access bug #248063 :(
Comment 6 Kenneth Hansen 2007-08-04 19:31:07 EDT
Btw the way, going on 2 week vacation now...yiihaaa

But will check as soon as I get back..maybe earlier if I'm in any ahem sober
state :)

Comment 7 Adam Tkac 2007-09-03 04:49:39 EDT

*** This bug has been marked as a duplicate of 253392 ***

Note You need to log in before you can comment on or make changes to this bug.