Bug 244024 - 2.6.9-55 breaks USB on W2100z so unusable
Summary: 2.6.9-55 breaks USB on W2100z so unusable
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Pete Zaitcev
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 13:06 UTC by Andrew Gormanly
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 00:20:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Gormanly 2007-06-13 13:06:25 UTC
Description of problem:
The latest kernel, 2.6.9-55, breaks USB on Sun Java Workstation W2100z's.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-55.EL.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Boot
2.
3.
  
Actual results:
Keyboard and mouse don't work (though kudzu does not detect the USB controllers
as missing).  The machine is therefore unusable.

Expected results:
Keyboard and mouse work, users are able to also.

Additional info:
I suspect this is due to a conflict with having 2 different USB hubs in the
machines:

[root@poisson ~]# lspci | grep USB
01:00.0 USB Controller: Advanced Micro Devices [AMD] AMD-8111 USB (rev 0b)
01:00.1 USB Controller: Advanced Micro Devices [AMD] AMD-8111 USB (rev 0b)
01:03.0 USB Controller: NEC Corporation USB (rev 43)
01:03.1 USB Controller: NEC Corporation USB (rev 43)
01:03.2 USB Controller: NEC Corporation USB 2.0 (rev 04)

It is possible to turn off the USB 2.0 controller in the BIOS setup (and then
the fifth output line above disappears), but not to turn off either all NEC or
all AMD controllers.

However, kernels up to 2.6.9-42.0.3.EL work fine, so the bug has been introduced
recently.  I did not try 2.6.9-42.0.10.EL yet, but can do so if it would help.

Comment 1 Jason Baron 2007-06-29 15:55:49 UTC
Can you be more specific and tell us the exact version of the last working kernel?

Comment 2 Andrew Gormanly 2007-06-29 17:34:58 UTC
Sure, but it will have to be Monday now as the machines have jobs running and
it's the weekend here.  I'll post when I have the results.

Comment 3 Andrew Gormanly 2007-07-03 13:59:58 UTC
Well, 2.6.9-42.0.10.EL works - but so does 2.6.9-55.0.2.EL so consider this fixed.


Comment 4 Pete Zaitcev 2007-09-19 00:20:03 UTC
Hmm, very odd. I wonder if it has something to do with with HCD load
order again.


Note You need to log in before you can comment on or make changes to this bug.