Bug 244055 - FC6 to FC7 yum upgrade appears broken as many FC6 higher version packages exist
FC6 to FC7 yum upgrade appears broken as many FC6 higher version packages exist
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
7
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 11:01 EDT by David Favor
Modified: 2013-01-09 20:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 12:46:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Favor 2007-06-13 11:01:48 EDT
Description of problem:

Following http://fedoraproject.org/wiki/YumUpgradeFaq produces unexpected
results of leaving hundreds of *.fc6.* packages installed because the
*.fc6.* packages are a higher/newer level than their fc7 counterparts.

Version-Release number of selected component (if applicable):

A random example is the paps package:

   The latest fc6 package is paps-0.6.6-20.fc6.i386.rpm

   The latest fc7 package is paps-0.6.6-19.fc7.i386.rpm from
   ftp://download.fedora.redhat.com/pub/fedora/linux/releases/7/...

This means after an upgrade the fc6 package remains installed,
as it's at a higher level.

In the past, after a yum upgrade all the package strings matched.
For example, going from fc5 -> fc6 only *.fc6.* packages were
installed after the upgrade.

Further 'rpm -qa | grep fc6 | wc -l' shows 414 fc6 packages
after an fc7 yum upgrade.

How reproducible:

Reproduced on two machines, with same result.

Steps to Reproduce:
1. Follow http://fedoraproject.org/wiki/YumUpgradeFaq
2. reboot (systems do boot)
3. 'rpm -qa | grep fc6 | wc -l'
  
Actual results:

Many unexpected *.fc6.* packages remain after fc7 upgrade.

Expected results:

Expected only *.fc7.* packages to be installed after upgrade.

Additional info:

Questions include:

1) Is an FC6 -> FC7 upgrade expected to leave hundreds of *.fc6*
   packages installed?

2) If not, what is the yum way (remote servers, so no CD/DVD access)
   to bring all these packages to their *.fc7.* versions?

Thanks.
Comment 1 Jesse Keating 2007-06-13 11:17:30 EDT
Are you sure you had both 'fedora' and 'updates' repos enabled?  Many updates
have been issued to Fedora 6 and Fedora 7 since the release of Fedora 7, and
thus what is in Fedora 6 now can be newer than the shipped Fedora 7 packages, so
you have to take into account the updates to Fedora 7.

Many Fedora 6 packages were inherited into Fedora 7 without rebuild.  It was not
necessary to rebuild them and they passed what QA we could give them, thus they
were inherited directly and still carry the .fc6 tag, so relying on just what
has .fc6 tags is not correct.  There are many packages which don't carry a tag
at all too.
Comment 2 David Favor 2007-06-13 11:46:34 EDT
Here's a symlink to my /etc/yum.repos.d directory:

   http://coolsurf.com/repo

It appears both fedora and fedora-update are both enabled.

'rpm -V fedora-release' passes quietly.

'rpm -qi fedora-release' shows version 7.3 as expected.

As for the inherited tags, I have seen this, hence my question.

And, as in the case of paps and many other packages, the FC6 level
exceeds the FC7 level. This means doing a CD/DVD install, then upgrade
will move packages from an *.fc7.* tag to an *.fc6.* tag.

So should doing a 'yum upgrade' over time, change fc7 packages to fc6 tags?
Comment 3 Jesse Keating 2007-06-13 12:46:09 EDT
Yes, if updates are issued to Fedora 7 that are a higher NVR than Fedora 6 they
will be updated.  We try to make sure that the NVR path from a fully updated
Fedora 6 will proceed correctly to a fully updated Fedora 7.  Sometimes we fail,
but we fix it when we can.  I'm going to close this NOTABUG as it isn't really a
bug in any software, just a process issue.
Comment 4 David Favor 2007-06-13 12:51:38 EDT
Just to be clear then.

After a plain CD/DVD install, future updates may change a package from
an *.fc7.* to *.fc6.* package name.

It may be worthwhile to put a single sentence about this in the upgrade
FAQ link mentioned above, to avoid future confusion.

Thanks for your assistance.

Note You need to log in before you can comment on or make changes to this bug.