Bug 244062 - Thunderbird crash on F7 x86_64
Thunderbird crash on F7 x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 11:21 EDT by Daniel Rowe
Modified: 2008-02-29 09:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 09:14:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace (14.18 KB, text/plain)
2007-06-14 09:25 EDT, Daniel Rowe
no flags Details
gdb t-bird crash debug output (24.12 KB, text/plain)
2007-07-19 22:30 EDT, Vince Schiavoni
no flags Details

  None (edit)
Description Daniel Rowe 2007-06-13 11:21:59 EDT
Description of problem:

Thunderbird crashes on Fedora 7 x86_64 on this box.

*** glibc detected *** /usr/lib64/thunderbird-2.0.0.0/thunderbird-bin: free():
invalid next size (fast): 0x00002aaab4f6f510 ***
======= Backtrace: =========
/lib64/libc.so.6[0x3bed470412]
/lib64/libc.so.6(cfree+0x8c)[0x3bed473b1c]
/usr/lib64/thunderbird-2.0.0.0/components/libwidget_gtk2.so[0x2aaab1394eac]
/usr/lib64/thunderbird-2.0.0.0/components/libwidget_gtk2.so[0x2aaab13a16a0]
/usr/lib64/thunderbird-2.0.0.0/components/libnsappshell.so[0x2aaab2939b99]
/usr/lib64/thunderbird-2.0.0.0/components/libnsappshell.so[0x2aaab2935b3f]
/usr/lib64/thunderbird-2.0.0.0/components/libnsappshell.so[0x2aaab293df2b]
/usr/lib64/thunderbird-2.0.0.0/components/libgklayout.so[0x2aaab3acad9c]
/usr/lib64/thunderbird-2.0.0.0/libxpcom_core.so(PL_HandleEvent+0x11)[0x3beca74a5d]
/usr/lib64/thunderbird-2.0.0.0/libxpcom_core.so(PL_ProcessPendingEvents+0x5f)[0x3beca74c6f]
/usr/lib64/thunderbird-2.0.0.0/libxpcom_core.so[0x3beca75ef9]
/usr/lib64/thunderbird-2.0.0.0/components/libwidget_gtk2.so[0x2aaab13969aa]
/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x1b4)[0x3bf2c2d1f4]
/lib64/libglib-2.0.so.0[0x3bf2c3002d]
/lib64/libglib-2.0.so.0(g_main_loop_run+0x1ca)[0x3bf2c3033a]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_main+0xa3)[0x3115f2dc93]
/usr/lib64/thunderbird-2.0.0.0/components/libwidget_gtk2.so[0x2aaab1396d8e]
/usr/lib64/thunderbird-2.0.0.0/components/libtoolkitcomps.so[0x2aaab1e8a8ae]
/usr/lib64/thunderbird-2.0.0.0/thunderbird-bin[0x408439]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x3bed41daa4]
/usr/lib64/thunderbird-2.0.0.0/thunderbird-bin(__gxx_personality_v0+0x199)[0x4039b9]
======= Memory map: ========
00400000-00418000 r-xp 00000000 fd:00 854702                            
/usr/lib64/thunderbird-2.0.0.0/thunderbird-bin
00618000-00624000 rw-p 00018000 fd:00 854702                            
/usr/lib64/thunderbird-2.0.0.0/thunderbird-bin
00624000-012d7000 rw-p 00624000 00:00 0                                  [heap]
40000000-40001000 ---p 40000000 00:00 0 
40001000-40a01000 rw-p 40001000 00:00 0 
40a01000-40a02000 ---p 40a01000 00:00 0 
40a02000-41402000 rw-p 40a02000 00:00 0 
41402000-41403000 ---p 41402000 00:00 0 
41403000-41e03000 rw-p 41403000 00:00 0 
41e03000-41e04000 ---p 41e03000 00:00 0 
41e04000-42804000 rw-p 41e04000 00:00 0 
42804000-42805000 ---p 42804000 00:00 0 
42805000-43205000 rw-p 42805000 00:00 0 
43205000-43206000 ---p 43205000 00:00 0 
43206000-43c06000 rw-p 43206000 00:00 0 
43c06000-43c07000 ---p 43c06000 00:00 0 
43c07000-44607000 rw-p 43c07000 00:00 0 
44607000-44608000 ---p 44607000 00:00 0 
44608000-45008000 rw-p 44608000 00:00 0 
45008000-45009000 ---p 45008000 00:00 0 
45009000-45a09000 rw-p 45009000 00:00 0 
45a09000-45a0a000 ---p 45a09000 00:00 0 
45a0a000-4640a000 rw-p 45a0a000 00:00 0 
4640a000-4640b000 ---p 4640a000 00:00 0 
4640b000-46e0b000 rw-p 4640b000 00:00 0 
3115a00000-3115a17000 r-xp 00000000 fd:00 8003744                       
/usr/lib64/libgdk_pixbuf-2.0.so.0.1000.12
3115a17000-3115c16000 ---p 00017000 fd:00 8003744                       
/usr/lib64/libgdk_pixbuf-2.0.so.0.1000.12
3115c16000-3115c17000 rw-p 00016000 fd:00 8003744                       
/usr/lib64/libgdk_pixbuf-2.0.so.0.1000.12
3115e00000-3116179000 r-xp 00000000 fd:00 2163302                       
/usr/lib64/libgtk-x11-2.0.so.0.1000.12
3116179000-3116379000 ---p 00379000 fd:00 2163302                       
/usr/lib64/libgtk-x11-2.0.so.0.1000.12
3116379000-3116383000 rw-p 00379000 fd:00 2163302                       
/usr/lib64/libgtk-x11-2.0.so.0.1000.12
3116383000-3116385000 rw-p 3116383000 00:00 0 
3116400000-311648f000 r-xp 00000000 fd:00 2163145                       
/usr/lib64/libgdk-x11-2.0.so.0.1000.12
311648f000-311668f000 ---p 0008f000 fd:00 2163145                       
/usr/lib64/libgdk-x11-2.0.so.0.1000.12
311668f000-3116694000 rw-p 0008f000 fd:00 2163145                       
/usr/lib64/libgdk-x11-2.0.so.0.1000.12
3216c00000-3216c07000 r-xp 00000000 fd:00 2163086                       
/usr/lib64/libpangoxft-1.0.so.0.1600.4
3216c07000-3216e06000 ---p 00007000 fd:00 2163086                       
/usr/lib64/libpangoxft-1.0.so.0.1600.4
3216e06000-3216e07000 rw-p 00006000 fd:00 2163086                       
/usr/lib6Aborted

Version-Release number of selected component (if applicable):

thunderbird-2.0.0.0-1.fc7

How reproducible:

Everytime
Comment 1 Christopher Aillon 2007-06-13 14:01:50 EDT
Can you install the debugging info for thunderbird to help us get a better idea
as to what's going on?

yum --enable=core-debuginfo install thunderbird-debuginfo

Then run:

gdb /usr/lib/thunderbird-2.0.0.0/thunderbird-bin

and type run when you get the prompt.

Please attach the crash output here.
Comment 2 Daniel Rowe 2007-06-14 07:52:50 EDT
[bart@bajor ~]$ gdb /usr/lib64/thunderbird-2.0.0.0/thunderbird-bin
GNU gdb Red Hat Linux (6.6-15.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
Using host libthread_db library "/lib64/libthread_db.so.1".
(gdb) run
Starting program: /usr/lib64/thunderbird-2.0.0.0/thunderbird-bin 
[Thread debugging using libthread_db enabled]
[New Thread 46912496392944 (LWP 32551)]
[New Thread 1084229968 (LWP 32554)]
[New Thread 1094719824 (LWP 32555)]
[New Thread 1105209680 (LWP 32560)]
[New Thread 1115699536 (LWP 32563)]
[New Thread 1126189392 (LWP 32564)]
[New Thread 1136679248 (LWP 32565)]
[New Thread 1147169104 (LWP 32566)]
[New Thread 1157658960 (LWP 32567)]
[Detaching after fork from child process 32568. (Try `set detach-on-fork off'.)]
[New Thread 1168148816 (LWP 32569)]
[New Thread 1178638672 (LWP 32570)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496392944 (LWP 32551)]
0x00002aaab2930ea3 in ~nsContentTreeOwner (this=0x1531090) at
nsContentTreeOwner.cpp:108
108       delete mSiteWindow2;
(gdb) 
Comment 3 Martin Stransky 2007-06-14 08:11:34 EDT
please attach full stack trace (by "thread apply all bt")

see
http://fedoraproject.org/wiki/StackTraces#head-0b97b385e6935f3bad0cda7586d78d8b7a3426f0
Comment 4 Daniel Rowe 2007-06-14 09:25:08 EDT
Created attachment 156991 [details]
stack trace

Stack trace attached.
Comment 5 Martin Stransky 2007-06-14 09:42:58 EDT
Are there any steps how to reproduce it? e.g. does it crash on some mail message
or just after start?
Comment 6 Vince Schiavoni 2007-07-19 22:30:46 EDT
Created attachment 159628 [details]
gdb t-bird crash debug output
Comment 7 Vince Schiavoni 2007-07-19 22:32:05 EDT
Hello:

I'm seeing a very similar problem with thunderbird crashing: only immediately
after start-up, and only when new POP (not IMAP) mail is available - t-bird
successfully fetches the mail, then freezes.  I am using
thunderbird-2.0.0.4-1.fc6.remi from remi's repo.  I realize that this release is
not Fedora's package, but this crash sure looks very familiar.  So I got
thunderbird-debuginfo-1.5.0.12.fc6 from the Fedora repos (since there wasn't any
more recent version available for FC6), and ran gdb as per the instructions
above.  The output is attached.  I hope that it is useful.  If not, sorry to
bother you.

Regards,
V
Comment 8 Vince Schiavoni 2007-07-23 04:25:49 EDT
Please disregard my Comment #7 and the accompanying attachment in Comment #6. 
After consulting with Remi Collet, and extensive testing of my add-ons, I have
determined that the freezes were caused by the Tango Icon Theme.

Sorry to have bothered you with this - I should have checked out the add-ons
first.  But perhaps the similarity of my crashes to the OP's problems suggests a
possibly similar source for his problems.  I'm sure that you are better
qualified to judge this.

Thanx Again and Regards,
Vince Schiavoni
Comment 9 Martin Stransky 2008-02-29 09:14:17 EST
okay, closing.

Note You need to log in before you can comment on or make changes to this bug.