Bug 244096 - ACPI: Critical trip point - Critical temperature reached, shutting down.
ACPI: Critical trip point - Critical temperature reached, shutting down.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 15:19 EDT by Frode Tennebø
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-29 15:39:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frode Tennebø 2007-06-13 15:19:44 EDT
Description of problem:

I upgraded from FC6 to F7 and only hours after rebooting into F7, the system 
shut down and I got this in /var/log/messages:

Jun 13 04:39:51 luke kernel: ACPI: Critical trip point
Jun 13 04:39:51 luke kernel: Critical temperature reached (3342 C), shutting 
down.
Jun 13 04:39:51 luke shutdown[5858]: shutting down for system halt
Jun 13 04:39:56 luke mountd[2148]: Caught signal 15, un-registering and exiting.
Jun 13 04:40:00 luke kernel: nfsd: last server has exited
Jun 13 04:40:00 luke kernel: nfsd: unexporting all filesystems
Jun 13 04:40:04 luke smartd[2031]: smartd received signal 15: Terminated
Jun 13 04:40:04 luke smartd[2031]: smartd is exiting (exit status 0)
Jun 13 04:40:05 luke xinetd[2079]: Exiting...
Jun 13 04:40:06 luke kernel: Critical temperature reached (63 C), shutting down.
Jun 13 04:40:09 luke kernel: md: stopping all md devices.
Jun 13 04:40:09 luke kernel: md: md0 still in use.
Jun 13 04:40:09 luke kernel: md: md1 still in use.
Jun 13 04:40:10 luke kernel: Synchronizing SCSI cache for disk sdb:
Jun 13 04:40:10 luke kernel: Synchronizing SCSI cache for disk sda:
Jun 13 04:40:10 luke ntpd[2098]: ntpd exiting on signal 15
Jun 13 04:40:11 luke kernel: ACPI: PCI interrupt for device 0000:02:02.0 
disabled

Current temperature is:

[root@luke log]# cat /proc/acpi/thermal_zone/THRM/temperature
temperature:             38 C

63 centigrades is highly unlikely, and, while it is summer, 3342 centigrades is 
inconceiveable, even for Norway.

Version-Release number of selected component (if applicable):

kernel-2.6.21-1.3194.fc7

How reproducible:

Don't know.  Bootet into an FC6 kernel.
Comment 1 Chuck Ebbert 2007-06-13 15:38:47 EDT
What kind of system did this happen on?

CPU vendor and model (from /proc/cpuinfo) would be useful too.
Comment 2 Frode Tennebø 2007-06-13 18:11:14 EDT
Ah! Sorry.

It's a Compaq Professional Workstation AP550.

[root@luke log]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 731.037
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat 
pse36 mmx fxsr sse
bogomips        : 1462.80
clflush size    : 32

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 731.037
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat 
pse36 mmx fxsr sse
bogomips        : 1461.84
clflush size    : 32

Comment 3 dominique 2007-06-29 01:53:36 EDT
what is the result of:
# cat /proc/acpi/thermal_zone/THRM/trip_points
Comment 4 Chuck Ebbert 2007-06-29 18:09:12 EDT
What drivers are loaded?
Post output of 'lsmod' please.
I ended up blacklisting some modules and my problem with this went away, as did
another reporter. We never did figure out what module was the root cause:

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229944
Comment 5 dominique 2007-07-01 01:25:37 EDT
(In reply to comment #3)
> what is the result of:
> # cat /proc/acpi/thermal_zone/THRM/trip_points
 or look this bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242369
Comment 6 Frode Tennebø 2007-07-01 05:28:09 EDT
I presume you'd like me to do this with the F7 kernel loaded, but I'm currently 
physically away from the system in question.  However, here's for the currently 
working kernel (fore completeness):


[ft@luke ~]$ uname -a
Linux luke 2.6.20-1.2948.fc6 #1 SMP Fri Apr 27 19:48:40 EDT 2007 i686 i686 i386 
GNU/Linux
[ft@luke ~]$ cat /proc/acpi/thermal_zone/THRM/trip_points
critical (S5):           95 C
passive:                 90 C: tc1=1 tc2=6 tsp=300 devices=0xefd0c554
active[0]:               79 C: devices=0xefd0ccfc
active[1]:               77 C: devices=0xefd0cc48
active[2]:               75 C: devices=0xefd106e4
active[3]:               73 C: devices=0xefd10630
active[4]:               71 C: devices=0xefd1057c
active[5]:               69 C: devices=0xefd104c8
active[6]:               67 C: devices=0xefd10414
active[7]:               65 C: devices=0xefd10360
active[8]:               63 C: devices=0xefd10c0c
active[9]:               27 C: devices=0xefd10b58
[root@luke ~]# lsmod
Module                  Size  Used by
vfat                   16193  0
fat                    53469  1 vfat
cdc_acm                18913  0
usb_storage            69121  0
nls_utf8                6209  1
cifs                  213329  1
sit                    14757  0
nvidia               3935180  8
nfsd                  208305  17
exportfs                9665  1 nfsd
autofs4                24261  2
nfs                   225229  2
lockd                  62665  3 nfsd,nfs
nfs_acl                 7617  2 nfsd,nfs
sunrpc                153469  13 nfsd,nfs,lockd,nfs_acl
ib_iser                37037  0
rdma_cm                29701  1 ib_iser
ib_cm                  34769  1 rdma_cm
iw_cm                  13381  1 rdma_cm
ib_sa                  18149  2 rdma_cm,ib_cm
ib_mad                 38369  2 ib_cm,ib_sa
ib_core                50881  6 ib_iser,rdma_cm,ib_cm,iw_cm,ib_sa,ib_mad
ib_addr                11845  1 rdma_cm
iscsi_tcp              26177  0
libiscsi               27329  2 ib_iser,iscsi_tcp
scsi_transport_iscsi    30025  4 ib_iser,iscsi_tcp,libiscsi
dm_multipath           21833  0
video                  19909  0
sbs                    19073  0
i2c_ec                  9025  1 sbs
dock                   13977  0
button                 11857  0
battery                13893  0
asus_acpi              20445  0
backlight              10177  1 asus_acpi
ac                      9157  0
ipv6                  275969  33 sit
lp                     16265  0
loop                   20041  0
snd_intel8x0           35677  2
snd_ac97_codec         93413  1 snd_intel8x0
ac97_bus                6465  1 snd_ac97_codec
snd_seq_dummy           7877  0
i2c_i801               11725  0
snd_seq_oss            33601  0
e100                   37705  0
serio_raw              10821  0
snd_seq_midi_event     11201  1 snd_seq_oss
snd_seq                51249  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
mii                     9409  1 e100
i2c_core               24897  2 i2c_ec,i2c_i801
snd_seq_device         11853  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            43616  0
intel_rng               9537  0
iTCO_wdt               15109  0
snd_mixer_oss          19393  2 snd_pcm_oss
iTCO_vendor_support     7877  1 iTCO_wdt
parport_pc             30053  1
parport                38537  2 lp,parport_pc
ata_piix               19141  0
snd_pcm                75205  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
libata                104789  1 ata_piix
pcspkr                  7233  0
floppy                 58789  0
snd_timer              25157  2 snd_seq,snd_pcm
snd                    53829  11 
snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              11681  2 snd
snd_page_alloc         13769  2 snd_intel8x0,snd_pcm
sg                     37213  0
dm_snapshot            20849  0
dm_zero                 6209  0
dm_mirror              25301  0
dm_mod                 58253  7 dm_multipath,dm_snapshot,dm_zero,dm_mirror
aic7xxx               137465  6
scsi_transport_spi     27201  1 aic7xxx
sd_mod                 24129  8
scsi_mod              138093  10 
usb_storage,ib_iser,iscsi_tcp,libiscsi,scsi_transport_iscsi,libata,sg,aic7xxx,scsi_transport_spi,sd_mod
raid456               123473  0
xor                    18121  1 raid456
raid1                  26433  2
ext3                  125641  2
jbd                    60777  1 ext3
ehci_hcd               34125  0
ohci_hcd               23493  0
uhci_hcd               26705  0

I'll check back in with data for the F7 kernel.
Comment 7 Michael Schwendt 2007-07-07 19:35:57 EDT
Same for me (I still see bug 155496), and also 65 C is realistic
here, a recent kernel update makes it impossible to alter the
trip points:

# echo -n "85:0:80:60:0" > /proc/acpi/thermal_zone/THRM/trip_points
-bash: echo: write error: Invalid argument
Comment 8 Michael Schwendt 2007-07-07 19:38:41 EDT
Scratch that, this ticket is about F7 not Rawhide.
Comment 9 dominique 2007-07-10 00:55:06 EDT
the good command is:
# echo 85:0:80:60:0 > /proc/acpi/thermal_zone/THRM/trip_points
Comment 10 Christopher Brown 2007-09-16 17:49:33 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 11 Frode Tennebø 2007-09-28 14:03:55 EDT
I have upgraded to kernel-2.6.22.5-76.fc7 (and previous releases).  All have 
behaved nicely.

Note You need to log in before you can comment on or make changes to this bug.