Bug 244115 - Apparent kernel bug with device names and substring matches
Summary: Apparent kernel bug with device names and substring matches
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 21:22 UTC by Chris Adams
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 21:43:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Adams 2007-06-13 21:22:53 UTC
I just installed a F7 system, using LVM (via kickstart).  I have named the
volume group "winwall" (the system name), and have two volumes named "usr" (for
/usr) and "usrlocal" (for /usr/local).  Anaconda wrote /etc/fstab with usrlocal
before usr, and so /usr/local is mounted first on boot.

This confuses something, apparently in the kernel.  "df /usr/local" and "fuser
-muv /usr/local" show results for /usr instead.  When I strace, it appears that
the kernel is where the problem is.  In df, statfs64("/usr/local/",...) returns
the size, space available, etc. for /usr.  In fuser, stat64("/usr/local/",...)
returns the device major/minor and the inode of the /usr/local directory in the
/usr filesystem.

If I unmount /usr/local and remount it (so it appears after /usr in /proc/mounts
and such), I don't see this behavior.  The statfs64() and stat64() calls return
the info about the /usr/local filesystem when they get to it, not /usr.

My guess would be that something is doing a substring match on the device name
instead of a full string match.

Comment 1 Chuck Ebbert 2007-06-13 21:34:25 UTC
How can /usr/local get mounted first?  There's nowhere to mount 
/usr/local until /usr gets mounted...


Comment 2 Chris Adams 2007-06-13 21:43:32 UTC
Sorry, no kernel bug here - all anaconda bug.  Anaconda created and mounted
/usr/local before /usr during install (the root filesystem has a /usr/local
directory so the mount succeeds, but then the /usr mount covers it up).


Note You need to log in before you can comment on or make changes to this bug.