Bug 244118 - Anaconda creates filesystem in the wrong order
Anaconda creates filesystem in the wrong order
Status: CLOSED DUPLICATE of bug 242294
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2007-06-13 17:50 EDT by Chris Adams
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-14 09:45:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2007-06-13 17:50:51 EDT
I have a kickstart that creates a /usr and a /usr/local (both LVM, with volume
names "usr" and "usrlocal").  This has worked fine for years, but with F7,
anaconda created and mounted /usr/local _before_ /usr (so the root filesystem
has the /usr/local mountpoint).  When /usr is created and mounted, it covers up
/usr/local, so /usr/local ends up empty.  The anaconda-written /etc/fstab is
also in the wrong order.

The kickstart file has them listed in the correct order (this is expanded by a
%pre script but otherwise a cut and paste):

logvol / --name=root --vgname=$vol --fstype=ext3 --size=$root
logvol swap --name=swap --vgname=$vol --fstype=swap --size=$swap
logvol /usr --name=usr --vgname=$vol --fstype=ext3 --size=$usr
logvol /var --name=var --vgname=$vol --fstype=ext3 --size=$var
logvol /tmp --name=tmp --vgname=$vol --fstype=ext3 --size=$tmp
logvol /usr/local --name=usrlocal --vgname=$vol --fstype=ext3 --size=$usrlocal

Anaconda sorts them (as it has always done) alphabetically; from anaconda.log:

20:12:29 INFO    : vg winwall, size is 38048, pesize is 32768
20:12:30 INFO    : lv is winwall/root, size of 512
20:12:30 INFO    : lv is winwall/swap, size of 640
20:12:30 INFO    : lv is winwall/tmp, size of 2016
20:12:30 INFO    : lv is winwall/usr, size of 2016
20:12:30 INFO    : lv is winwall/usrlocal, size of 22976
20:12:30 INFO    : lv is winwall/var, size of 8000

But then when it gets to making the filesystems, it shuffles them:

20:13:44 INFO    : formatting swap as swap
20:13:44 INFO    : formatting / as ext3
20:13:44 INFO    : Format command:  ['mke2fs', '/dev/winwall/root', '-i',
'4096', '-j']

20:13:47 INFO    : formatting /boot as ext3
20:13:47 INFO    : going to run: ['mdadm', '--create', '/dev/md0', '--run',
'--chunk=256', '--level=1', '--raid-devices=2', '/dev/sda1', '/dev/sdb1']
20:13:48 INFO    : starting raid device md0
20:13:48 INFO    : mdadm -E /dev/sda1
20:13:48 INFO    : mdadm -A --uuid=12c32f1e:e7e4b407:9cbce141:9bf40208
--super-minor=0 /dev/md0
20:13:48 INFO    : Format command:  ['mke2fs', '/dev/md0', '-i', '4096', '-j']

20:13:48 INFO    : starting raid device md0
20:13:48 INFO    : formatting /var as ext3
20:13:48 INFO    : Format command:  ['mke2fs', '/dev/winwall/var', '-i', '4096',

20:14:00 INFO    : formatting /usr/local as ext3
20:14:00 INFO    : Format command:  ['mke2fs', '/dev/winwall/usrlocal', '-i',
'4096', '-j']

20:14:30 INFO    : formatting /tmp as ext3
20:14:31 INFO    : Format command:  ['mke2fs', '/dev/winwall/tmp', '-i', '4096',

20:14:35 INFO    : formatting /usr as ext3
20:14:35 INFO    : Format command:  ['mke2fs', '/dev/winwall/', '-i', '4096',,
Comment 1 Chris Lumens 2007-06-14 09:45:56 EDT

*** This bug has been marked as a duplicate of 242294 ***

Note You need to log in before you can comment on or make changes to this bug.