Bug 244151 - "Asymptote" uses wrong viewer defaults
"Asymptote" uses wrong viewer defaults
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: asymptote (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jose Pedro Oliveira
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 02:37 EDT by Joachim Frieben
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.29-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 11:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2007-06-14 02:37:26 EDT
Description of problem:
When using "asymptote" in interactive mode, it wants to use "acroread"
for displaying "PDF" files (e.g. when typing "help") and "gv" for
displaying "EPS" files rendered by itself.

Version-Release number of selected component (if applicable):
asymptote-1.29-1.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Launch "asymptote" interactive session.
2. Type "help".
3. Create new figure.
  
Actual results:
The help file is displayed by "acroread", the "PS" file does not get
displayed because "gv" is not installed.

Expected results:
The different files are displayed using the "F7" default viewer which is
"evince" for both document types.

Additional info:
By setting both "ASYMPTOTE_PSVIEWER" and "ASYMPTOTE_PDFVIEWER" to "evince",
the correct behaviour is achieved. However, this setting should be the
default one, especially when "gv" is a deprecated application, and
"acroread" is not even open source.
Comment 1 Jose Pedro Oliveira 2007-06-16 16:40:01 EDT
I believe this patch will solve the problem:

-----------
diff -ruN asymptote-1.29-orig/settings.cc asymptote-1.29/settings.cc
--- asymptote-1.29-orig/settings.cc     2007-05-19 18:25:56.000000000 +0100
+++ asymptote-1.29/settings.cc  2007-06-16 21:16:06.000000000 +0100
@@ -72,11 +72,11 @@
 bool msdos=false;
 const char *HOME="HOME";
 const char pathSeparator=':';
-string defaultPSViewer="gv";
+string defaultPSViewer="evince";
 #ifdef __APPLE__
 string defaultPDFViewer="open";
 #else  
-string defaultPDFViewer="acroread";
+string defaultPDFViewer="evince";
 #endif  
 string defaultGhostscript="gs";
 string defaultDisplay="display";
-----------

If everything goes according to the plan I will push a new release tomorrow.

jpo
Comment 2 Jose Pedro Oliveira 2007-06-17 11:37:55 EDT
asymptote 1.30 has already been built (for FC-6, F-7, and devel) and should
start appearing soon in the mirrors (already being pushed for rawhide; no ETA
for FC-6 and F-7).

Please re-open this ticket if the problem persists.

jpo


Note You need to log in before you can comment on or make changes to this bug.