Bug 244153 - jasper: should not depend on freeglut
Summary: jasper: should not depend on freeglut
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jasper   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-14 07:17 UTC by Braden McDaniel
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 15:38:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Braden McDaniel 2007-06-14 07:17:33 UTC
More accurately, the package that contains libjasper should not depend on
freeglut. I suspect the Right Thing is for jiv to be broken out into a separate
package.

Comment 1 Rex Dieter 2007-06-14 11:46:00 UTC
> libjasper should not depend on freeglut

rationale?  why?

Comment 2 Braden McDaniel 2007-06-14 14:46:05 UTC
Since libjasper itself does not depend on freeglut, applications that use
libjasper should not wind up depending on freeglut.


Comment 3 Rex Dieter 2007-06-14 15:15:07 UTC
I'll consider it. 
We first need to make sure no apps that use libjasper may want/need/use jiv.

Comment 4 Braden McDaniel 2007-06-14 15:50:46 UTC
That's a good point; instead, libjasper could be broken out into a libjasper
package. Any package that currently uses jiv (or another executable in the
distribution) should have an explicit "Requires: jasper"; any package that only
links with libjasper should not.

That should prevent dependencies from getting broken.


Comment 5 Rex Dieter 2007-06-21 00:17:19 UTC
Or stick with the status quo, where everything "just works", and just live with
the extra ~400k that freeglut takes on your disk. :)

Comment 6 Braden McDaniel 2007-06-21 00:31:20 UTC
And OpenGL. And X11.

There's no reason a machine serving as an image processing server should have to
have X11 installed.


Comment 7 Rex Dieter 2007-06-21 01:03:33 UTC
I'm not aware of anything in Fedora that links against libjasper, but not
libX11, am I wrong?

Comment 8 Braden McDaniel 2007-06-21 02:44:33 UTC
I don't know. But as long as it is reasonable for users to create/install RPMs
that complement the Fedora package set, I'm not sure why that matters.


Comment 9 Rex Dieter 2007-08-22 15:38:34 UTC
%changelog
* Wed Aug 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.900.1-4
- -libs subpkg to be multilib friendlier
- -utils subpkg for non-essential binaries jiv, tmrdemo (#244153)

going into rawhide real soon.


Note You need to log in before you can comment on or make changes to this bug.