Bug 244155 - xsane is unable to scan only shows a black box
xsane is unable to scan only shows a black box
Status: CLOSED DUPLICATE of bug 243953
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 03:47 EDT by cornel panceac
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 13:46:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2007-06-14 03:47:37 EDT
Description of problem:

i started xsane to scan some documents. first, acquired preview showed the doc
ok, while scanning it produced in viewer a black box.
 itried playing with settings (preferences) and the result was that the preview
no longer showed the doc, but instead the same black box. i've searched with yum
and found some packages containing the string "sane" and i've installed 
python-imaging-sane
and

sane-frontends
starting xsane again makes no difference.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.start xsane
2.acquire preview
3.scan
  
Actual results:
preview and viewer_after_scan shows only a black box (wich can be saved in
whatever format)


Expected results:
preview shows the document and so does the viewer_after_scan.

Additional info:
on the same computer, the scanner worked on fc6, and still works on another
machine wich runs centos 5.0

scanimage -L says:
device `plustek:libusb:001:005' is a Canon N670U/N676U/LiDE20 USB flatbed scanner
(on f7)

 rpm -q xsane
xsane-0.994-3.fc7

rpm -q sane-backends
sane-backends-1.0.18-6.fc7

uname -a
Linux 2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT 2007 i686 i686 i386 GNU/Linux
Comment 1 Nils Philippsen 2007-06-14 04:55:38 EDT
Please get the latest FC6 kernel:

http://redhat.download.fedoraproject.org/pub/fedora/linux/core/updates/6/i386/kernel-2.6.20-1.2952.fc6.i686.rpm

Install it ("rpm -ivh --oldpackage ..."), reboot into that kernel and report
back whether this makes a difference.

If the latest kernel of FC6 doesn't work, please try the first FC6 kernel as well:

http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/kernel-2.6.18-1.2798.fc6.i686.rpm
Comment 2 cornel panceac 2007-06-14 12:25:29 EDT
sorry, but i am on f7, as you can see above. fc6 was fine.
Comment 3 Nils Philippsen 2007-06-14 16:55:36 EDT
I am aware that you are on F7, that's why I listed the URLs to the package
files. Please do try the FC6 kernel on F7 and report back whether this makes a
difference.
Comment 4 cornel panceac 2007-06-15 03:15:47 EDT
ok, here's what i've done: installed 2952 and rebooted with the "new" kernel.
xsane worked perfectly on preview. 
then i rebooted on the latest f7 kernel and everything was black.
then rebooted again on 2952 and did some actual scanning. everyting worked.
rebooted again on f7 (2.6.21-1.3194.fc7) and pressed "scan" instead of "preview"
it worked. i scanned again, worked again. i closed xsane, started, scan, worked.
pressed "preview" and was all black, then "scan" all black, restart xsane,
"scan" all black. restarted computer into 3194 again, xsane, scan, all black.
and it stayed black. 
Comment 5 cornel panceac 2007-06-15 03:23:19 EDT
maybe it worth mentioning that, the very first time i started xsane on f7, the
preview was fine, then the scan was black, then everything stayed black.
Comment 6 Nils Philippsen 2007-06-15 03:42:39 EDT
I'll change the component to kernel so the kernel maintainers can evaluate
whether the regression introduced is a) a bug in the kernel or b) a legitimate
change that reveals an up to now hidden bug in userspace.
Comment 7 cornel panceac 2007-06-15 03:48:00 EDT
thank you very much!
Comment 8 Chuck Ebbert 2007-06-15 13:46:58 EDT

*** This bug has been marked as a duplicate of 243953 ***

Note You need to log in before you can comment on or make changes to this bug.