This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 244165 - invalid timezones Etc/GMT-13, Etc/GMT-14
invalid timezones Etc/GMT-13, Etc/GMT-14
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tzdata (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 05:36 EDT by Alexander Todorov
Modified: 2015-05-04 21:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 11:48:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2007-06-14 05:36:24 EDT
Description of problem:
According to:
http://www.worldtimezone.com/index24.php
http://wwp.greenwichmeantime.com/time-zone/time-zones.htm

there is no timezone GMT-13, GMT-14, officially there are 25 timezones:
GTM, GMT+/-12

Version-Release number of selected component (if applicable):
system-config-date-1.8.12-1.el5


How reproducible:
Always

Steps to Reproduce:
1. run system-config-date
2. choose teb "Time zone"
3. expand "Non geographic timezones"
  
Actual results:
There are Etc/GMT-13 and Etc/GMT-14 timezones.

Expected results:
There should be timezones up to GMT+/-12 only.

Additional info:
This affect Anaconda because it uses system-config-date to allow time zone
settings before installation.
Comment 1 Nils Philippsen 2007-06-14 07:26:18 EDT
system-config-date uses all the timezones found beneath /usr/share/zoneinfo,
e.g. the "Etc/GMT-13" timezone corresponds with the file
/usr/share/zoneinfo/Etc/GMT-13 which is contained in the tzdata package ->
changing component.
Comment 2 Alexander Todorov 2007-06-14 07:46:25 EDT
$ rpm -q tzdata
tzdata-2007d-1.el5
Comment 3 Petr Machata 2007-06-26 11:48:12 EDT
GMT time zones used to be the only alternative for countries that were not
covered by the zoneinfo "proper" zones.  By now, most of the inhabited world is
covered by proper zones, but GMT zones remain for backwards compatibility, and
for nautical use.

The -13 and -14 zones in particular were used for countries that are on the edge
of the international date line, so that they are don't end up having different
dates on east and west coast.  They have no nautical use, because, as you said,
only -12..+12 makes sense in general; so I guess they are only present for
backwards compatibility.
Comment 4 Alexander Todorov 2007-06-26 12:02:19 EDT
As there is not official timezone GMT-13/14 how do these countries solve the
issue. IMO they stick to some of the official zones. I think this is problem is
in  the competency of those who define timezones. As software dewelopers we
don't have to solve the problems but stick to the rules.

Note You need to log in before you can comment on or make changes to this bug.