This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 244166 - Berkeley DB's license specified incorrectly in RPM License field
Berkeley DB's license specified incorrectly in RPM License field
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 05:38 EDT by Mark Schreiber
Modified: 2013-07-02 19:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 06:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Schreiber 2007-06-14 05:38:37 EDT
Description of problem:
The db4-4.5.20.5.fc7 RPM's license is specified as being "BSD-style". 
"BSD-style" licenses allow incorporation of a package into other proprietary
packages.  This does not reflect Berkeley DB's license.  Versions of Berkeley DB
prior to v2.0 are, according to Wikipedia, under a license that looks something
like the BSD license with some GPL additions.  Versions at and above 2.0 are
available under a commercial license (currently available from Oracle) or under
the Sleepycat Public License (
http://opensource.feratech.com/licenses/sleepycat.php ), which is rather like a
strict GPL -- any software package that so much as uses this package must also
provide source code.

Version-Release number of selected component (if applicable):4.5.20.5.fc7


How reproducible:rpm -qi db4 and look at the License field


Steps to Reproduce:
1.rpm -qi db4
2.
3.
  
Actual results:BSD-style


Expected results:"Sleepycat License"


Additional info:
Comment 1 Jindrich Novy 2007-06-18 06:39:15 EDT
The BSD-style license was suggested by Red Hat legal department and therefore I
won't change it since I'm not a lawier.

Note You need to log in before you can comment on or make changes to this bug.