Bug 244168 - proftpd pam problem
Summary: proftpd pam problem
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: proftpd   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-14 09:45 UTC by Hubert Thumfart
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.3.0a-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 20:04:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filename: /etc/pam.d/proftpd, pam_stack is not available in F7, use include (228 bytes, text/plain)
2007-06-14 09:45 UTC, Hubert Thumfart
no flags Details

Description Hubert Thumfart 2007-06-14 09:45:33 UTC
Description of problem: Problem with login to proftpd (pam)


Version-Release number of selected component (if applicable):


How reproducible: try to login


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: pam_stack is not available in F7, use include

Comment 1 Hubert Thumfart 2007-06-14 09:45:33 UTC
Created attachment 156973 [details]
filename: /etc/pam.d/proftpd, pam_stack is not available in F7, use include

Comment 2 Matthias Saou 2007-06-15 16:30:29 UTC
Oh, thanks! I guess (almost) everybody sticks to vsftpd nowadays, since this
hasn't been reported earlier. Note that while testing the change, I realized
that authentication does not work with selinux enabled. But this doesn't seem
like a new problem either...

avc:  denied  { execute } for  pid=20643 comm="proftpd" name="unix_update"
dev=sda1 ino=1173045 scontext=user_u:system_r:ftpd_t:s0
tcontext=system_u:object_r:updpwd_exec_t:s0 tclass=file

PAM(foo): Authentication service cannot retrieve authentication info.

I've pushed an F7 update to fix the PAM problem. I'm not sure what needs to be
done to fix the selinux one, though. Have the system policy updated?

Comment 3 Fedora Update System 2007-06-16 13:21:37 UTC
proftpd-1.3.0a-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2007-06-20 20:04:36 UTC
proftpd-1.3.0a-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.