Bug 244178 - yum-updatesd and rpmq consume 100% CPU, unresponsive
Summary: yum-updatesd and rpmq consume 100% CPU, unresponsive
Status: CLOSED DUPLICATE of bug 245389
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-14 12:36 UTC by Liam Dennehy
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-23 00:13:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Liam Dennehy 2007-06-14 12:36:04 UTC
Description of problem:
yum-updatesd in high-CPU loop, does not respond to regular kill command, SIGKILL
terminates process. When I tried to use rpm -qi to query version number for this
bug report, rpmq got stuck in a high-CPU loop instead. Again, SIGKILL is only
way to terminate rpmq.

Version-Release number of selected component (if applicable):
rpm: 4.4.2
yum-updatesd: unknown (rpm query hangs)

How reproducible:
each time I run rpm command. Has happened multiple times before, until I
discovered SIGKILL reboot was only remedy.

Steps to Reproduce:
1. Leave box on for indeterminate amount of time
2. let yum-updatesd start
3.
  
Actual results:
python /usr/sbin/yum-updatesd consumes all available CPU time
rpmq consumes all available CPU time

Expected results:
yum-updatesd: update query occurs without intervention
rpmq: query results returned immediately

Additional info:

Comment 1 Jeff Johnson 2007-06-16 02:45:40 UTC
After SIGKILL, you *must* do
    rm -f /var/lib/rpm/__db*
or you will have a stale lock.

Otherwise yum-updatesd behavior has nothing to do with rpm.

Comment 2 Liam Dennehy 2007-06-23 00:14:06 UTC

*** This bug has been marked as a duplicate of 245389 ***


Note You need to log in before you can comment on or make changes to this bug.