Bug 244180 - path for root's cronjobs is missing the sbin directories
path for root's cronjobs is missing the sbin directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 08:49 EDT by David Jansen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 11:41:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2007-06-14 08:49:31 EDT
In earlier fedora (and RHEL) versions, root's cron jobs had
/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin as their path, 
whereas Fedora 7 only has /bin and /usr/bin . Nothing important of course, but
it breaks scripts that don't actually add the full path to the programs they call.

Version-Release number of selected component (if applicable):
vixie-cron-4.1-82.fc7.i386

In case this matters: I was using cron jobs entered through 'crontab -e', jobs
in /etc/cron.* seem to be unaffected due to the PATh setting that happens in
/etc/crontab. As far as I could find out, no cronjobs supplied by Fedora are
affected, since they all reside in /etc/cron.* . So maybe it is not a bug, but
just a change in behaviour that needed to be documented?
Comment 1 Marcela Mašláňová 2007-07-16 09:33:09 EDT
Well, I look at every branch and I didn't find paths set on
/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin. Which version of
cron did you meant? I can add it as a feature, no problem.
Comment 2 Marcela Mašláňová 2007-07-16 11:41:40 EDT
Hm I reconsider my opinion. I'll write a line in manual pages, because I find
out that this setting of paths is for security. The paths are read from system
like _PATH_DEFPATH, which is set on /bin and /usr/bin. Other /sbin paths are not
allowed for non root users. 

Fix of manual will be in rawhide.

Note You need to log in before you can comment on or make changes to this bug.