Bug 244198 - Intel Audio Device undetected.
Intel Audio Device undetected.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 10:10 EDT by Rui Gouveia
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 08:53:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log (48.13 KB, text/plain)
2007-06-14 10:10 EDT, Rui Gouveia
no flags Details
scsrun.log (196 bytes, text/plain)
2007-06-14 10:11 EDT, Rui Gouveia
no flags Details
scsconfig output (57.26 KB, text/plain)
2007-07-09 17:57 EDT, Ted Markowitz
no flags Details
scsrun output (241 bytes, text/plain)
2007-07-09 17:58 EDT, Ted Markowitz
no flags Details

  None (edit)
Description Rui Gouveia 2007-06-14 10:10:41 EDT
Description of problem:

audio not detected


Version-Release number of selected component (if applicable):
Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio
Controller (rev 02)

How reproducible:
every time.

Steps to Reproduce:
1. run system-config-soundcard.
2. try to play sound.
3.
  
Actual results:
no sound

Expected results:
sound

Additional info:
Comment 1 Rui Gouveia 2007-06-14 10:10:41 EDT
Created attachment 156999 [details]
scsconfig.log
Comment 2 Rui Gouveia 2007-06-14 10:11:27 EDT
Created attachment 157000 [details]
scsrun.log
Comment 3 Martin Stransky 2007-06-26 10:46:04 EDT
Hm, the logs look sane. Can you check the latest drivers? (1.0.14). how-to is
here: http://people.redhat.com/stransky/alsa/
Comment 4 Ted Markowitz 2007-07-09 17:57:40 EDT
Created attachment 158813 [details]
scsconfig output
Comment 5 Ted Markowitz 2007-07-09 17:58:22 EDT
Created attachment 158814 [details]
scsrun output
Comment 6 Ted Markowitz 2007-07-09 17:59:43 EDT
I think I might be seeing the same problem, but having more data points might
help pinpoint the issue. I have a brand-new Dell Latitude Core 2 Duo D830
running 2.6.21-1.3228.fc7 (32-bit) using the Intel Corporation 82801H (ICH8
Family) HD Audio Controller (rev 02). The card never gets loaded properly at
startup and is unconfigurable thereafter using system-config-soundcard. I'll
attach the 2 requested log files as well. FYI: Here's what dmesg shows when I
try to load the drivers from system-config-soundcard:

usbcore: deregistering interface driver snd-usb-audio
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21 (level, low) -> IRQ 20
PCI: Setting latency timer of device 0000:00:1b.0 to 64
ALSA
/var/tmp/bach-build/BUILD/alsa-driver-1.0.14/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:558:
hda_intel: azx_get_response timeout, switching to polling mode...
ALSA
/var/tmp/bach-build/BUILD/alsa-driver-1.0.14/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:564:
hda_intel: azx_get_response timeout, switching to single_cmd mode...
hda_codec: No auto-config is available, default to model=ref
ALSA
/var/tmp/bach-build/BUILD/alsa-driver-1.0.14/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:1020:
hda-intel: no codecs initialized
ACPI: PCI interrupt for device 0000:00:1b.0 disabled
usbcore: registered new interface driver snd-usb-audio
Comment 7 Ted Markowitz 2007-07-09 18:02:21 EDT
I forgot to mention that I had already downloaded and installed the most recent
corresponding alsa kernel module for release 3228, but the problem was still
there and these logs show those results.

--Ted
Comment 8 Ted Markowitz 2007-07-11 18:52:53 EDT
I punted F7 and dropped back to using FC6 on my Core 2 Duo Dell D830 since I was
having so many issues with F7: not being able to find the soundcard, can't
access the DVD drive, freezing intermittently, etc. I updated FC6 to the latest
version of all the ALSA stuff I could find from the ALSA site (FC6
2.6.20-1.2962) and tried seeing whether the Intel 82801H controller was now
visible and enabled. Alas, the effect is exactly the same: no usable sound. The
dmesg output from FC6 is the same as I submitted in comment #6. 

I'd LOVE to get the sound working on my new machine (everything else appears
functional now) and would really appreciate any help to get me there. Is there
anything else I can try or any possible workarounds? I'm game to test new
solutions or patches, if it might help. Please let me know.

Cheers,

--Ted
Comment 9 Martin Stransky 2007-08-16 08:53:13 EDT
It's a problem in drivers, see:

ALSA
/var/tmp/bach-build/BUILD/alsa-driver-1.0.14/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:564:
hda_intel: azx_get_response timeout, switching to single_cmd mode...

hda_codec: No auto-config is available, default to model=ref
ALSA
/var/tmp/bach-build/BUILD/alsa-driver-1.0.14/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:1020:
hda-intel: no codecs initialized
ACPI: PCI interrupt for device 0000:00:1b.0 disabled

Please create a report at ALSA project (www.alsa-project.org) and attach the log
there. They're authors of linux sound system and should be able to help you...

Note You need to log in before you can comment on or make changes to this bug.