Bug 244208 - SELinux policy update for RHEL 5.1 Xen update
SELinux policy update for RHEL 5.1 Xen update
Status: CLOSED DUPLICATE of bug 249895
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 10:53 EDT by Chris Lalancette
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 11:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2007-06-14 10:53:14 EDT
Description of problem:
When doing an "xm reboot" with the new RHEL 5.1 xen bits, it fails to restart
the guest (and actually put xend into a funky state, which is a whole other
issue).  The problem is that "xm reboot" calls out to pygrub, which, in the
latest bits, needs access to /usr/lib/fs (or /usr/lib64/fs on x86_64).  However,
SELinux is preventing xend (which is in context root:system_r:xend_t) from
accessing these files, causing the reboot to fail.  In particular, pygrub is
attempting to pathconf("/usr/lib/fs"), and is getting -EPERM back.

Unfortunately I do not have AVC's from this; I think I screwed up the audit
daemon on this machine, so I'm not getting anything out anymore.

If you need access to a box to see this in action, please let me know; I have a
machine available here that shows the problem.
Comment 1 RHEL Product and Program Management 2007-06-14 11:05:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 RHEL Product and Program Management 2007-07-03 10:10:52 EDT
Since Keyword Regression exists, this is a blocker,
not an exception.  Cleared exception flag.
Set blocker flag."
Comment 3 Daniel Walsh 2007-07-03 13:39:51 EDT
Ok this bug is useless to me,  In current policy xm is allowed to read lib_t
which is what /usr/lib/fs should be labeled as.  So I have no idea what the
problem is.
Comment 4 Chris Lalancette 2007-07-03 13:48:23 EDT
Hm, OK.  I assume I would have to collect AVC's for this to be useful?  I'll try
re-installing a 5.1 system from scratch and see if I can get some information
out of audit; disabling SELinux did solve the problem for me initially, so I
figured it was somewhere in there.  I'll get back to you when I have more info.

Chris Lalancette
Comment 5 Chris Lalancette 2007-08-10 11:37:26 EDT

*** This bug has been marked as a duplicate of 249895 ***

Note You need to log in before you can comment on or make changes to this bug.