Bug 244232 - ntfs-config problems
ntfs-config problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ntfs-config (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 12:35 EDT by Joshua Jensen
Modified: 2013-01-09 23:21 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0-0.4.rc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 18:36:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of ntfs-config sucking (42.77 KB, image/jpeg)
2007-06-14 12:35 EDT, Joshua Jensen
no flags Details
requested output (26.34 KB, text/plain)
2007-06-18 15:05 EDT, Joshua Jensen
no flags Details
ntfs-config as root (8.34 KB, text/plain)
2007-06-20 16:45 EDT, Joshua Jensen
no flags Details

  None (edit)
Description Joshua Jensen 2007-06-14 12:35:47 EDT
Description of problem:

You all need an ntfs-config component!

ntfs-config does not understand LVM or /dev/mapper fstab entries.  This is a
basic functionality problem, and needs to be fixed.

See attached screenshot

Version-Release number of selected component (if applicable):

ntfs-config-1.0-0.3.rc4.fc7.noarch
Comment 1 Joshua Jensen 2007-06-14 12:35:48 EDT
Created attachment 157019 [details]
screenshot of ntfs-config sucking
Comment 2 Xavier Lamien 2007-06-18 13:58:09 EDT
Could you give me the following ouput command ?

# ntfs-config --d -q all

and

# more /proc/partitions

Just print them to standard text file and upload them somehere.

thanks
Comment 3 Joshua Jensen 2007-06-18 15:05:24 EDT
Created attachment 157315 [details]
requested output
Comment 4 Florent Mertens 2007-06-20 07:08:04 EDT
Hi Joshua,

Thanks for the debugging information. But you should have a look at the warning :
"
WARNING : Query database without root privilege.
WARNING : Result might be incomplete.
"

The "#" standed for "run me as root".
ntfs-config resolve mapped device node path with dmsetup that need to be run
as root.

Could you redo this step again as root. Thanks.

Other than that all looks ok. dm-* partition are all resolved as slaves of sda2,
but since it can't get there node path, it ignore them.

But i think there might be a problem anyway. After getting mapped device name 
with dmsetup, it will assume that they are aall in /dev/mapper, which seems to
be not  your case. It probably need to get some basic info from lvm. 

In a try to get this info, could you attach the output of :

# lvscan -b

Tell me if you know better command than that.

Thanks.
Comment 5 Joshua Jensen 2007-06-20 16:43:23 EDT
Output from lvscan -b:

  ACTIVE            '/dev/VolGrp0/fc5_root' [10.00 GB] inherit
  ACTIVE            '/dev/VolGrp0/data-old' [110.00 GB] inherit
  ACTIVE            '/dev/VolGrp0/home' [68.38 GB] inherit
  ACTIVE            '/dev/VolGrp0/swap' [2.00 GB] inherit
  ACTIVE            '/dev/VolGrp0/f7_root' [10.00 GB] inherit
  ACTIVE            '/dev/VolGrp0/fc6_root' [10.00 GB] inherit
  ACTIVE            '/dev/VolGrp0/data' [85.00 GB] inherit
Comment 6 Joshua Jensen 2007-06-20 16:45:21 EDT
Created attachment 157494 [details]
ntfs-config as root
Comment 7 Florent Mertens 2007-06-20 18:34:05 EDT
Why in the hell there is a '-b' options if it don't do what it is intended to do.
Anyway, i think i'll just setup an lvm volume and see what i can do with it.

Thanks a bunch mate, i promise that next version will handle that just right.
Comment 8 Xavier Lamien 2007-06-21 10:33:04 EDT
Florent, thanks for having come to comment about this bug outside of your main
bug report platform for your ntfs-config apps.

Don't forget to report me for some fix, i will look around too ;)

Comment 9 Xavier Lamien 2007-06-26 04:56:39 EDT
It should be fix in RC5.
i'll build it and make some test before import it and bring back some feedback.
Comment 10 Xavier Lamien 2007-06-26 17:40:05 EDT
The RC5 has been built and sounds work.
However i'd like to have an external test and feedback before push it to STABLE.

Josuha, if you don't mind, will you test it with your LVM set ?

here the link:
http://koji.fedoraproject.org/packages/ntfs-config/1.0/0.4.rc5.fc7/noarch/ntfs-config-1.0-0.4.rc5.fc7.noarch.rpm
Comment 11 Joshua Jensen 2007-06-26 18:00:31 EDT
Very nice... it doesn't complain about device mapper devices anymore.
Comment 12 Xavier Lamien 2007-06-26 18:36:35 EDT
okay :)

Other branch were built, i'll push them to stable.

Thanks Josuha.

Note You need to log in before you can comment on or make changes to this bug.