Bug 244239 - javascript bug ?
javascript bug ?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 13:27 EDT by Teguh DC
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 09:21:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Teguh DC 2007-06-14 13:27:18 EDT
Description of problem:
firefox consume all CPU time in some cases:

examples #1: firefox runs at 100% CPU usage all the time
http://www.detik.com

example #2: firefox runs big amount of cpu
http://www.okezone.com

It is likely javascript problem, i dunno javascript at both site is bad, or
firefox bug.


Version-Release number of selected component (if applicable):
2.0.0.4-2.fc7

How reproducible:
alway

Steps to Reproduce:
1. just open both site
2.
3.
  
Actual results:


Expected results:


Additional info:
after i disable js on firefox, cpu usage is normal
Comment 1 Matěj Cepl 2007-06-26 12:32:53 EDT
Cannot reproduce here with firefox-2.0.0.4-2.fc7. http://www.detik.com is
totally flawless for me, information boxes (I guess) on the bottom of
http://www.okezone.com take a lot of CPU power, but still I cannot reproduce
100% CPU usage. Maybe your hardware is just getting slow under those (arguably
pretty bad) scripts?

Please, try to provide more information about how to reproduce this, otherwise I
will have to close this bug as unreproducible.
Comment 2 Teguh DC 2007-06-27 01:10:21 EDT
I try with IBM T60 Laptop. my friend using ibm t43 also found this bug.
But when i try using desktop, which is slower machine than my laptop, cpu usage
is not high as ibm t60.

firefox-2.0.0.4-2.fc7

[root@boncos ~]# cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 14
model name      : Genuine Intel(R) CPU           T2400  @ 1.83GHz
stepping        : 8
cpu MHz         : 1000.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc pni monitor vmx
est tm2 xtpr
bogomips        : 3661.24
clflush size    : 64

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 14
model name      : Genuine Intel(R) CPU           T2400  @ 1.83GHz
stepping        : 8
cpu MHz         : 1000.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc pni monitor vmx
est tm2 xtpr
bogomips        : 3657.58
clflush size    : 64

[root@boncos ~]# free
             total       used       free     shared    buffers     cached
Mem:       1033948     421420     612528          0      23980     186716
-/+ buffers/cache:     210724     823224
Swap:      1048568          0    1048568
Comment 3 Teguh DC 2007-08-07 15:45:10 EDT
Better performance after upgrade to firefox-2.0.0.5-1.fc7
Comment 4 Matěj Cepl 2007-08-15 09:21:57 EDT
Closing per comment 3. If you feel that firefox's speed needs some improvement
(and I won't argue with you about it), then you should probably file/join the
bug upstream.

Note You need to log in before you can comment on or make changes to this bug.