Bug 244256 - pam_keyring does not prevent prompt for keyring password
pam_keyring does not prevent prompt for keyring password
Status: CLOSED DUPLICATE of bug 238741
Product: Fedora
Classification: Fedora
Component: pam_keyring (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 14:35 EDT by Matthew Saltzman
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 15:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2007-06-14 14:35:19 EDT
Description of problem:
After logging in, NetworkManager's wireless connection manager asks for a key
form the keyring, and the keyring password prompt appears.

Version-Release number of selected component (if applicable):
pam_keyring-0.0.8-3.fc6

How reproducible:
Always (or almost always)

Steps to Reproduce:
1. Install and configure pam_keyring for gdm.
2. Log in.
3. Do something that requires keyring access.
  
Actual results:
Keyring pasword dialog pops up.

Expected results:
Keyring password dialog does not pop up.

Additional info:
My keyring and login password are identical.

My /etc/pam.d/gdm contains the following:

    #%PAM-1.0
    auth       required    pam_env.so
    # auth       sufficient  pam_unix.so likeauth nullok
    auth       optional    pam_keyring.so try_first_pass
    auth       include     system-auth
    account    required    pam_nologin.so
    account    include     system-auth
    password   include     system-auth
    session    optional    pam_keyinit.so force revoke
    session    include     system-auth
    session    required    pam_loginuid.so
    session    optional    pam_console.so
    session    optional    pam_keyring.so

The problem occurs with F7 kernels (kernel-2.6.21-1.3194.fc7 and
kernel-2.6.21-1.3228.fc7), but not with the latest FC6 kernel
(kernel-2.6.20-1.2952.fc6).

Behavior is the same with the "auth sufficient" line uncommented.  With the FC6
kernel, commenting the "auth sufficient" line is required to get it to work.
Comment 1 Denis Leroy 2007-06-14 15:16:11 EDT
Known problem, expect a fix soon.


*** This bug has been marked as a duplicate of 238741 ***

Note You need to log in before you can comment on or make changes to this bug.