Bug 244257 - error installing fedora-gpg-key for flash plugin
Summary: error installing fedora-gpg-key for flash plugin
Status: CLOSED DUPLICATE of bug 246564
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-14 18:37 UTC by Ric
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 07:07:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ric 2007-06-14 18:37:56 UTC
Description of problem: error when trying to install fedora-gpg-key


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. su --login
2. rpm --import http://macromedia.mplug.org/FEDORA-GPG-KEY
  
Actual results:
" warning: cannot get exclusive lock on /var/lib/rpm/Packages "


Expected results:
ehh, doing the job? It had worked many other times.


Additional info:

Fresh install F7, full updated, I am following
http://www.fedorasolved.org/browser-solutions/flash/ this howto has always work.

[crash@localhost ~]$ su -c 'yum -y update'
Contraseña:
Loading "installonlyn" plugin
Setting up Update Process
No Packages marked for Update/Obsoletion
[crash@localhost ~]$ su --login
Contraseña:
[root@localhost ~]# rpm --import http://macromedia.mplug.org/FEDORA-GPG-KEY
warning: cannot get exclusive lock on /var/lib/rpm/Packages
[root@localhost ~]#

Comment 1 Andre Robatino 2007-06-14 19:45:41 UTC
  This probably means that some other process such as yum-updatesd or rpmq
currently has a lock on the database.  Try again later.  Someone I was helping
got the same warning during a rpm --import command, but it worked later.

Comment 2 Ric 2007-06-14 21:36:50 UTC
Tried several times, for around 6h, no luck, it worked flawlessly after a reboot
(!!!)...

Comment 3 Andre Robatino 2007-06-14 21:39:54 UTC
  If it actually requires a reboot, then the lock isn't getting released after
the other process is finished, which _would_ be a bug.  I don't remember whether
the person I was helping rebooted between the time it failed and when it
succeeded, but it's possible.

Comment 4 Jeff Johnson 2007-06-16 02:50:04 UTC
Yep. Contention for an rpmdb lock is orders of magnitude worse
now that yum has *several* competing daemons.

Doing
    rm -f /var/lib/rpm/__db*
and attempting the --import before the next acquisition of the rpmdb lock
by yum-updatesd is recommended.

Comment 5 Panu Matilainen 2007-08-15 08:24:42 UTC
Sounds like a possible side-effect of bug 245389, which in short appears to be
setroubleshoot tracebacking a lot for some people and causing stale rpmdb locks
to be left behind. The rpm package from updates-testing should help, if not 100%
fix the problem.


Comment 6 Panu Matilainen 2007-08-24 07:07:07 UTC

*** This bug has been marked as a duplicate of 246564 ***


Note You need to log in before you can comment on or make changes to this bug.