Bug 244281 - Torcs segmentation fault when car touches other objects
Torcs segmentation fault when car touches other objects
Status: CLOSED DUPLICATE of bug 203336
Product: Fedora
Classification: Fedora
Component: torcs (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-06-14 15:59 EDT by Markus Lindholm
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-16 16:44:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
torcs log (882 bytes, text/plain)
2007-06-14 15:59 EDT, Markus Lindholm
no flags Details

  None (edit)
Description Markus Lindholm 2007-06-14 15:59:01 EDT
Description of problem:
The game always crashes after the start of the race and when the player's car
makes contact with an other car.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start torcs
2. Start a race 
3. Drive into an other car or barrier
Actual results:
Segmentation fault

Expected results:

Additional info:
Tried a few different race courses and a few different cars to make contact with
- the same result
Comment 1 Markus Lindholm 2007-06-14 15:59:02 EDT
Created attachment 157038 [details]
torcs log
Comment 2 Matthias Saou 2007-06-15 05:18:02 EDT
This rings a bell. It has already been reported a while ago, but IIRC it got
fixed in some external library which was causing the problem. I've searched
bugzilla for the relevant report(s), but since they are no longer filed against
torcs, and since I don't remember which library it was, I didn't find them... :-/

Hans : Do you happen to remember the issue and the fix? I think it was you who
tracked down the problem and fixed it already...

Still, I'm surprised to see a new report of this against F7.
Comment 3 Hans de Goede 2007-06-15 07:08:52 EDT
This is not the same problem, the last time torcs crashed when using openAL
sound, you can try disabling openAL as soundsystem though to see if openAL is
the problem again.
Comment 4 Markus Lindholm 2007-06-15 12:40:42 EDT
Tested to change the sound system and Torcs seg faults only if openAL is selected.
Comment 5 Matthias Saou 2007-06-15 12:47:25 EDT
Seems like the openal bug is back!
Could you please check what openal packages you have installed, just in case?
Who knows, maybe you have some lod-ish package from some 3rd party repository,
which doesn't contain the fix...
Comment 6 Markus Lindholm 2007-06-15 12:56:02 EDT
[mli@zeus ~]$ rpm -qi openal
Name        : openal                       Relocations: (not relocatable)
Version     : 0.0.9                             Vendor: Fedora Project
Release     : 0.9.20060204cvs.fc7           Build Date: Tue 07 Nov 2006 06:33:22
Install Date: Thu 07 Jun 2007 10:51:17 PM CEST      Build Host:
Group       : System Environment/Libraries   Source RPM:
Size        : 420639                           License: LGPL
Signature   : DSA/SHA1, Mon 21 May 2007 06:58:54 PM CEST, Key ID b44269d04f2a6fd2
Packager    : Fedora Project <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.openal.org/
Summary     : Open Audio Library
Description :
OpenAL is an audio library designed in the spirit of OpenGL--machine
independent, cross platform, and data format neutral, with a clean,
simple C-based API.
Comment 7 Hans de Goede 2007-06-16 16:44:13 EDT
GRRR, this is bug 203336 al over again, which I indeed did write a patch for,
but that never got applied to the package in CVS?? (actually the bug is still
open) Please add comments to bug 203336 requesting for this to be fixed asap!

*** This bug has been marked as a duplicate of 203336 ***

Note You need to log in before you can comment on or make changes to this bug.