Bug 244298 - rhnreg_ks ends up with a conflict if config mgmt option is enabled in activation key
rhnreg_ks ends up with a conflict if config mgmt option is enabled in activat...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Beth Nackashi
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 16:51 EDT by Pradeep Kilambi
Modified: 2010-10-22 11:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0815
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:34:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2007-06-14 16:51:45 EDT
Description of problem:
ok I found the problem...In your key if you goto configuration option there is a
check box at the bottom thats checked 

" Schedule a deploy action for all of the configuration files in the channels
listed above upon system registration."

What this means is that automatically add rhncfg to the transaction set if you
are deploying..that why its running rhncfg as a separate transaction at the
bottom...If you disable that check box everything should be working fine..and in
this instance up2date is set to error if rhncfg is already installed.

So thats how it is as of now.. we can open an issue for 4.6 to hanle this so
up2date in config option enable case will try to recheck the package existance.

For now we should be good as its not going to break any other package installs.
Its gonna raise the conflict error as a separate transaction for rhncfg package
alone..but still install the rest of the packages successfully in the akey list.
Comment 1 Pradeep Kilambi 2007-06-14 17:00:32 EDT
to add little more info:

[root@gss6-245 up2date_client]# rhnreg_ks --serverUrl=http://10.65.6.86/XMLRPC
--activationkey=f75eb036312b52da7384dbb5a2bb91d5 --force
####################### ['curl', 'rhncfg', 'rhncfg-actions', 'rhncfg-client',
'sysreport']

Name                                    Version        Rel     
----------------------------------------------------------


The following packages you requested are already updated:
curl
curl
curl
curl
curl
curl
curl
curl
curl
curl
rhncfg
rhncfg
rhncfg
rhncfg
rhncfg
rhncfg
rhncfg
rhncfg
rhncfg-actions
rhncfg-actions
rhncfg-actions
rhncfg-actions
rhncfg-actions
rhncfg-actions
rhncfg-actions
rhncfg-actions
rhncfg-client
rhncfg-client
rhncfg-client
rhncfg-client
rhncfg-client
rhncfg-client
rhncfg-client
rhncfg-client
sysreport
sysreport
sysreport
sysreport
sysreport
%%%%%%%%%%%%%%%%%%%%%%%%% [['rhncfg', '5.0.1', '1.el4', ''], ['rhncfg-actions',
'5.0.1', '1.el4', ''], ['rhncfg-client', '5.0.1', '1.el4', '']]

Name                                    Version        Rel     
----------------------------------------------------------
rhncfg                                  5.0.1          1.el4             noarch
rhncfg-actions                          5.0.1          1.el4             noarch
rhncfg-client                           5.0.1          1.el4             noarch


rhncfg is added in as a seperate transaction and in/var/logup2date
Fri Jun 15 02:50:20 2007] up2date successfully retrieved authentication token
from up2date server
[Fri Jun 15 02:50:22 2007] up2date RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package rhncfg-5.0.1-1.el4 is already installed
package rhncfg-client-5.0.1-1.el4 is already installed
package rhncfg-actions-5.0.1-1.el4 is already installed
Comment 2 RHEL Product and Program Management 2007-06-14 17:06:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Pradeep Kilambi 2007-06-15 13:10:14 EDT
I guess something like this should fix the rhncfg issue:

Index: up2dateBatch.py
===================================================================
--- up2dateBatch.py     (revision 117585)
+++ up2dateBatch.py     (working copy)
@@ -11,6 +11,7 @@
 import rhnPackageInfo
 import wrapperUtils
 from rhpl.translate import _, N_
+from up2date_client import rpmUtils        
 
 
 # later...
@@ -174,6 +175,8 @@
         """
         selPackages = []
         actionPkgNVREA = map(lambda x:x[:4],self.actionPkgListInfo)
+        installedPkgs = rpmUtils.getInstalledPackageList(getArch=1)
+        installedPkgsNVREA = map(lambda x:x[:4], installedPkgs)
         # If action pkgs for update/install 
         if actionPkgNVREA:
             # this loop could be faster leaving it in for now
@@ -183,6 +186,9 @@
             for pkg in self.allAvailablePackages:
                 if pkg[0] in skippedPkgs:
                     continue
+                if pkg[:4] in installedPkgsNVREA:
+                    #skip if package already installed
+                    continue
                 if pkg[:4] in actionPkgNVREA:
                     selPackages.append(pkg)
 
Comment 6 Colin Coe 2007-06-27 22:34:29 EDT
This effects RHEL3 nodes also.  Could this fix be applied to RHEL also?

CC
Comment 7 Colin Coe 2007-06-27 22:35:16 EDT
That should have read: Could this fix be applied to RHEL3 also?
Comment 8 J Ponds 2007-07-20 02:40:07 EDT
If I uncheck the checkbox: " Schedule a deploy action for all of the 
configuration files in the channels listed above upon system registration."
the config files are not deployed!!!!
Comment 10 RHEL Product and Program Management 2007-07-25 16:44:17 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.
Comment 15 errata-xmlrpc 2007-11-15 11:34:21 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0815.html

Note You need to log in before you can comment on or make changes to this bug.