This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 244339 - Compiler Segmentation Faults When Compiling DarkIce
Compiler Segmentation Faults When Compiling DarkIce
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
http://darkice.tyrell.hu/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 02:20 EDT by Adam D. Ligas
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 04:23:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Compiler Preprocessed Source (60.94 KB, application/octet-stream)
2007-06-15 02:20 EDT, Adam D. Ligas
no flags Details

  None (edit)
Description Adam D. Ligas 2007-06-15 02:20:10 EDT
Description of problem:
When trying to compile DarkIce 0.18.1, the compiler throws a segmentation fault
due to an "internal compiler error" and crashes.


Version-Release number of selected component (if applicable):
gcc version 4.1.2 20070502 (Red Hat 4.1.2-12)


How reproducible:
Configure and compile DarkIce

Steps to Reproduce:
1. Install LAME
2. Install ALSA-LIB-DEVEL
3. Configure DarkIce (./configure)
4. Run Make (make)
  
Actual results:
Things go alright until the following occurs...
g++ -DHAVE_CONFIG_H -I. -I/usr/local/include       -O2 -pedantic -Wall   -g -O2
-MT aflibDebug.o -MD -MP -MF .deps/aflibDebug.Tpo -c -o aflibDebug.o aflibDebug.cc
aflibDebug.cc:163: internal compiler error: Segmentation fault

Expected results:
Program should compile cleanly, and then run.

Additional info:
The compiler generated a "Preprocessed source" and asked me to attach it to the
bug report - I have done so.

This computer is registered via smolt.  I updated the profile prior to sending
this report. 
http://smolt.fedoraproject.org/show?UUID=708abba1-8424-4333-89b9-e4a8d484441c

I don't compile very much, so although I am willing to do whatever I can to
assist, I should be probably considered a "compiler newbie" experience wise.
Comment 1 Adam D. Ligas 2007-06-15 02:20:10 EDT
Created attachment 157061 [details]
Compiler Preprocessed Source
Comment 2 Adam D. Ligas 2007-06-15 02:28:19 EDT
Just a small update.  I totally misinterpreted the "How reproducible" question.
 Bad bug reporter *SMACK* :)

This bug is reproducible 100% of the time.
Comment 3 Jakub Jelinek 2007-06-15 04:23:18 EDT
Sorry, can't reproduce this on the attached preprocessed source.
gcc-c++-4.1.2-12's cc1plus compiles this just fine, many times in a row.
Comment 4 Jakub Jelinek 2007-06-15 04:36:53 EDT
What you actually could do if you can reproduce it all the time would be
install gcc-debuginfo-4.1.2-12.i386.rpm
and then run
gdb --args /usr/libexec/gcc/i386-redhat-linux/4.1.2/cc1plus -fpreprocessed
244339.ii -quiet -dumpbase 244339.ii -mtune=generic -auxbase-strip 244339.o -g
-O2 -O2 -pedantic -Wall -o 244339.s -frandom-seed=0
and under gdb
run
and if it segfaults, do bt, info regs etc.
But as it is not reproduceable here, it will be certainly much harder to debug.
Comment 5 Adam D. Ligas 2007-06-15 05:10:32 EDT
Stangeness abound!

After you replied you could not reproduce the error, I tried to compile the
program again.  The same error continued to occur each time.

When you sent the gdb instructions, I decided to give it a go.  I installed the
gcc-debuginfo package via yum, ran gdb with your parameters, and then executed
the make again.  The software built successfully!

I then removed the gcc-debuginfo package, extracted a fresh copy of the software
source, and tried to rebuild without gdb again.  Success!

Could installing/removing the gcc-debuginfo package have knocked something back
into line?  Its the only thing I have changed since the initial report - the
hardware hasn't even been rebooted or anything.

P.S. - Thank you for your quite speedy and helpful responses.

Note You need to log in before you can comment on or make changes to this bug.