Bug 244342 - kppp broken
kppp broken
Product: Fedora
Classification: Fedora
Component: kpppload (Show other bugs)
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Ngo Than
Depends On:
  Show dependency treegraph
Reported: 2007-06-15 03:38 EDT by Need Real Name
Modified: 2008-06-16 21:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-06-15 03:38:21 EDT
Description of problem:  kppp does not work

Version-Release number of selected component (if applicable):

How reproducible:  it doesn't work period.

Steps to Reproduce:
1.  try to run it.
2.  doesn't get past point of dialog box where it says 'initializing modem'
Actual results:  nothing happens - modem is not activate

Expected results:  dialer should be activated

Additional info:
I'm using an ordinary US Robotics 56k modem on first physical serial port of the
pc.  Note that kppp worked perfect with fc5, was broken with fc6, and has not
been fixed with f7.
Comment 1 Gianluca Varisco 2007-06-17 09:07:44 EDT
Can you try to attach the KPPP log (KPP -> Configure -> View Logs;
Comment 2 Need Real Name 2007-06-18 03:47:27 EDT
Actually, the log does not exist. :-(  I presume this is so because I cannot,
and have not, ever made a connection to the Internet.  I have the external modem
set up on /dev/ttyS0 (note:  /dev/modem does not work at all, never has, in any
version of Fedora I have tried).  When I try connecting to the Internet, it says
initializing modem, and nothing else happens no matter how long I wait.  If I
display the log, nothing appears in it.  Note as well, in the modem setup, when
I do the modem query, no data shows up in the query results.  I have noticed one
bit of info which may be of interest - in MS Windows XP, the modem only has the
CS light on when there is no active connection with the Internet (the modem
works correctly with Windows).  With Fedora, when there is no active connection,
the CS light AND the TR light are lit up.  From my understanding, the TR light
should not be lit up when no connection is active.  So it appears that Fedora is
doing something to the modem that it should not be doing.  Hopefully this info
will help you find a fix for the problem.  
Comment 3 Bug Zapper 2008-05-14 09:06:26 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2008-06-16 21:36:06 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.