Bug 244350 - TTY input audit support
TTY input audit support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: readline (Show other bugs)
6.0
All Linux
high Severity low
: rc
: ---
Assigned To: Lukáš Nykrýn
Iveta Wiedermann
: FutureFeature, Reopened
Depends On: 244135
Blocks: 756082
  Show dependency treegraph
 
Reported: 2007-06-15 04:31 EDT by Miloslav Trmač
Modified: 2012-06-20 09:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This version adds advisory TTY input audit events, to record the lines actually reported to applications.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:43:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Create advisory TTY audit events (1.65 KB, patch)
2007-06-15 04:31 EDT, Miloslav Trmač
no flags Details | Diff
The patch submitted upstream (2.63 KB, patch)
2007-12-05 19:04 EST, Miloslav Trmač
no flags Details | Diff

  None (edit)
Description Miloslav Trmač 2007-06-15 04:31:03 EDT
The attached patch adds advisory TTY input audit events, to record the lines
actually reported to applications (in addition to the raw stream of keystrokes,
which might be very hard to interpret).
Comment 1 Miloslav Trmač 2007-06-15 04:31:03 EDT
Created attachment 157073 [details]
Create advisory TTY audit events
Comment 2 Miloslav Trmač 2007-12-05 19:04:15 EST
Created attachment 278931 [details]
The patch submitted upstream
Comment 3 RHEL Product and Program Management 2008-06-04 18:49:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 RHEL Product and Program Management 2008-06-23 17:05:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 RHEL Product and Program Management 2008-06-24 11:57:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 RHEL Product and Program Management 2008-07-21 19:10:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 13 RHEL Product and Program Management 2009-04-02 04:25:17 EDT
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request.
Comment 17 RHEL Product and Program Management 2009-11-06 13:45:16 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 19 RHEL Product and Program Management 2010-08-09 14:19:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 20 RHEL Product and Program Management 2011-01-11 15:20:01 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 21 RHEL Product and Program Management 2011-01-11 18:25:30 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 24 RHEL Product and Program Management 2011-01-17 18:19:10 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 26 RHEL Product and Program Management 2011-07-05 20:04:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 31 Lukáš Nykrýn 2012-02-15 08:58:42 EST
patch submitted to git -> http://post-office.corp.redhat.com/archives/cvs-commits-list/2012-February/msg04902.html -> modified
Comment 34 Lukáš Nykrýn 2012-04-10 08:37:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This version adds advisory TTY input audit events, to record the lines actually reported to applications.
Comment 36 Dalibor Pospíšil 2012-05-29 10:34:51 EDT
An automated test has been created, see https://tcms.engineering.redhat.com/case/138646/for-TTY-auditing .
Comment 39 errata-xmlrpc 2012-06-20 09:43:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0834.html

Note You need to log in before you can comment on or make changes to this bug.