Bug 244367 - gnome-default-printer doesn't set printer as default
Summary: gnome-default-printer doesn't set printer as default
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2007-06-15 09:51 UTC by Cedric Verkleeren
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 14:18:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cedric Verkleeren 2007-06-15 09:51:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
When I set a default printer using gnome-default-printer, the printer seems to be set as default but when lauching gnome-default-printer again, the default printer is not selected. I get this behaviour when I am logged on as simple user not as root.
Using strace, I see we store informations in ~/.cups/lpoptions when I am logged on as simple user. And the informations are stored in /etc/cups/lpotions when I am logged on as root.

Version-Release number of selected component (if applicable):
desktop-printing-0.19-21

How reproducible:
Always


Steps to Reproduce:
1.log on as simple user
2.launch gnome-default-printer
3.select a printer to set as default
4.launch gnome-default-printer again

Actual Results:
the default printer hasn't changed

Expected Results:
the default printer selected must be the one I have previously selected

Additional info:

Comment 1 Tim Waugh 2007-06-15 10:27:59 UTC
The default printer has actually changed for that user, it's just that the
application does not display that correctly and shows the system default instead
of the user default.

I think it also needs a 'Use System Default' button.


Comment 2 Tim Waugh 2007-07-20 14:18:15 UTC
The system-config-printer implementation provides this button now.


Note You need to log in before you can comment on or make changes to this bug.