This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 24439 - Pnews requires inews, and inews has hidden requirements for inn.
Pnews requires inews, and inews has hidden requirements for inn.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: trn (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-19 19:51 EST by rhaig
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 11:32:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rhaig 2001-01-19 19:51:07 EST
inews requires that /etc/news/inn.conf exist. The only information it needs
from this file is the name of the news server. This is silly.

from bug# 6003
=======
The code should be fixed to send the article at hand to the server listed
in /etc/nntpserver,$NNTPSERVER or something on the command line to Pnews
(defaulting to "news" if none is present).
=======

I actually have time to work on a patch to do this.  So, I'll work on that
and submit it to redhat (in this bug) and to isc for inclusion in the next
version of the INN source.


Also, inews should be it's own component.
Comment 1 rhaig 2001-02-07 17:36:59 EST
after looking at the source and how it's organized, there's not a good way to
add this functionality to inews.  The problem is in posting articles on a client
machine that doesn't have inn installed.  

It appears that the best fix for this is to write a replacement for inews that
can be used by Pnews for posting news.  

There is not a Pnews component, so It probably needs to be changed to the trn
component.  

I'll investigate changing Pnews to use inews if it exists, or use another
program instead.  (shouldn't be too difficult, but might require Net::NNTP perl
module)

I'll change the component and the summary to match the above notes.
Comment 2 rhaig 2001-02-07 19:32:55 EST
found solution to problem.

it involves changes to the file layout in the (broken) inn rpm.
INN should have it's own inews, preferably in /usr/local/news/bin, or since
redhat has an aversion to rpms in /usr/local, perhaps it should lie in
/usr/news/bin instead (along with all the other inn related programs).

the inews that comes with the TRN package solves this problem.  it behaves as it
should, and therefore should be included with the trn package.  

for more info on the proper trn package, please refer to
http://sourceforge.net/projects/trn

This bug is now an RPM layout problem.  the base directory of INN needs to be
changed and the full TRN package needs to be shipped.  Although TRN is currently
4.0Beta, this shouldn't be a problem.  When wanting to ship beta products, just
Refer to Alan's explaination of why the gcc beta was shipped.  TRN 4.0 is the
best trn out there for your customers, therefore it should be shipped.
Comment 3 Florian La Roche 2001-02-13 08:40:59 EST
inews from inn-2.3.1 should work much better without the rest of the inn
nstalled.
Can yu test if that newest inews works for you without having inn installed?
Comment 4 rhaig 2001-02-13 11:32:25 EST
the inews from INN 2.3.1 worked without libraries or config files from the rest
of INN being installed.  I've tested it using the NNTPSERVER environment
variable to determine the news server.  I'll look at the code this afternoon and
see what other options there are for determining the server and test those
(although I'm sure they'll work, it's mainly to see if I need to add any).
At that point, I'll comment the bug again, and change it's status to resolved
currentrelease with a note that it's the release if INN that fixed inews.
Comment 5 Florian La Roche 2001-02-14 05:39:12 EST
Ok, the current inews rpm is changed to not depend on inn

Note You need to log in before you can comment on or make changes to this bug.