Bug 244487 - gschem missing needed dependencies in rpm
gschem missing needed dependencies in rpm
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: geda-gschem (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-15 21:17 EDT by Chris Caudle
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 22:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum log (18.85 KB, text/plain)
2007-06-16 12:40 EDT, Chris Caudle
no flags Details
the output of rpm -qR geda-gschem (981 bytes, text/plain)
2007-06-16 12:42 EDT, Chris Caudle
no flags Details

  None (edit)
Description Chris Caudle 2007-06-15 21:17:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc7 Firefox/2.0.0.4

Description of problem:
Clean install of F7 on X86_64 system.  Installed geda-gschem and friends with graphical yum tool, but gschem bailed out when run with missing library messages.
To get gschem running, I had to install:
libstroke
libgeda

Version-Release number of selected component (if applicable):
geda-gschem-20070216-1.fc7hem-20070216-1.fc7

How reproducible:
Always


Steps to Reproduce:
1.Install F7 clean.
2.Install geda-* tools from software update application, Applications/Engineering and Scientific
3.run gschem

Actual Results:
gschem failed to run with message:
gschem: error while loading shared libraries: libstroke.so.0: cannot open shared object file: No such file or directory
Installed libstroke by hand using yum.  Run gschem again and get message:
gschem: error while loading shared libraries: libgeda.so.28: cannot open shared object file: No such file or directory.
Install libgeda by hand using yum, gschem runs properly.

Expected Results:
geda-gschem package should specify libstroke and libgeda as dependency, yum should install packages to satisfy dependency.

Additional info:
Comment 1 Chitlesh GOORAH 2007-06-16 06:06:56 EDT
Something is broken somewhere, because yum should pull those dependencies by 
itself.

Can you give me the output of

rpm -qR geda-gschem 

please ?

Was your installation successfully ?
Comment 2 Chris Caudle 2007-06-16 12:40:08 EDT
Created attachment 157195 [details]
yum log

This is the log showing geda-gschem being installed on June 14.  Libgeda was
not installed until June 15 when I installed in by hand.
Comment 3 Chris Caudle 2007-06-16 12:42:16 EDT
Created attachment 157196 [details]
the output of rpm -qR geda-gschem

The output of rpm -qR geda-gschem shows libgeda and libstroke, so it is not
obvious why yum did not pull those two libraries in automatically.
Comment 4 Chris Caudle 2007-06-16 22:58:11 EDT
I removed libgeda and libstroke using yum, and it correctly insisted on removing
all the geda-* packages because of dependencies.  I re-installed geda-gschem
using yum, and it pulled in libstroke and libgeda like it should.
I have no idea why it failed the first time.  Maybe I was pulling from an out of
date mirror or something.
Anyway, since the behavior can not be duplicated, this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.