Bug 244496 - madwifi and network manager have trouble connecting (wpa2)
madwifi and network manager have trouble connecting (wpa2)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-16 01:00 EDT by Jussi Eloranta
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 20:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jussi Eloranta 2007-06-16 01:00:37 EDT
Description of problem:

The madwifi (all the recent version that I have tried) and NetworkManager
(gnome) have trouble connecting to wpa2 network (apple airport express).
This is with all the latest updates installed.

I see the following in my /var/log/messages:

Jun 10 18:16:50 epatto1 NetworkManager: <info>  Will activate connection
'ath0/epatto'. 
Jun 10 18:16:51 epatto1 NetworkManager: <info>  Device ath0 activation scheduled... 
Jun 10 18:16:51 epatto1 NetworkManager: <info>  Activation (ath0) started... 
Jun 10 18:16:51 epatto1 NetworkManager: <info>  Activation (ath0) Stage 1 of 5
(Device Prepare) scheduled... 
Jun 10 18:16:51 epatto1 NetworkManager: <info>  Activation (ath0) Stage 1 of 5
(Device Prepare) started... 
Jun 10 18:16:51 epatto1 NetworkManager: <info>  Activation (ath0) Stage 2 of 5
(Device Configure) scheduled... 
Jun 10 18:16:51 epatto1 NetworkManager: <info>  Activation (ath0) Stage 1 of 5
(Device Prepare) complete. 
Jun 10 18:16:52 epatto1 NetworkManager: <info>  Activation (ath0) Stage 2 of 5
(Device Configure) starting... 
Jun 10 18:16:52 epatto1 NetworkManager: <info>  Activation (ath0/wireless):
access point 'epatto' is encrypted, but NO valid key exists.  New key needed. 
Jun 10 18:16:52 epatto1 NetworkManager: <info>  Activation (ath0) New wireless
user key requested for network 'epatto'. 
Jun 10 18:16:52 epatto1 NetworkManager: <info>  Activation (ath0) Stage 2 of 5
(Device Configure) complete. 
Jun 10 18:16:52 epatto1 NetworkManager: <info>  Activation (ath0) New wireless
user key for network 'epatto' received. 
Jun 10 18:16:53 epatto1 NetworkManager: <info>  Activation (ath0) Stage 1 of 5
(Device Prepare) scheduled... 
Jun 10 18:16:53 epatto1 NetworkManager: <info>  Activation (ath0) Stage 1 of 5
(Device Prepare) started... 
Jun 10 18:16:53 epatto1 NetworkManager: <info>  Activation (ath0) Stage 2 of 5
(Device Configure) scheduled... 
Jun 10 18:16:53 epatto1 NetworkManager: <info>  Activation (ath0) Stage 1 of 5
(Device Prepare) complete. 
Jun 10 18:16:54 epatto1 NetworkManager: <info>  Activation (ath0) Stage 2 of 5
(Device Configure) starting... 
Jun 10 18:16:54 epatto1 NetworkManager: <info>  Activation (ath0/wireless):
access point 'epatto' is encrypted, and a key exists.  No new key needed. 
Jun 10 18:16:54 epatto1 NetworkManager: <info>  SUP: sending command
'INTERFACE_ADD ath0                wext    /var/run/wpa_supplicant ' 
Jun 10 18:16:54 epatto1 kernel: ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready
Jun 10 18:16:54 epatto1 NetworkManager: <info>  SUP: response was 'OK' 
Jun 10 18:16:54 epatto1 NetworkManager: <info>  SUP: sending command 'AP_SCAN 1' 
Jun 10 18:16:55 epatto1 NetworkManager: <info>  SUP: response was 'OK' 
Jun 10 18:16:55 epatto1 NetworkManager: <info>  SUP: sending command 'ADD_NETWORK' 
Jun 10 18:16:55 epatto1 NetworkManager: <info>  SUP: response was '0' 
Jun 10 18:16:56 epatto1 NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 ssid 65706174746f' 
Jun 10 18:16:56 epatto1 NetworkManager: <info>  SUP: response was 'OK' 
Jun 10 18:16:56 epatto1 NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 proto WPA2' 
Jun 10 18:16:57 epatto1 NetworkManager: <info>  SUP: response was 'OK' 
Jun 10 18:16:57 epatto1 NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 key_mgmt WPA-PSK' 
Jun 10 18:16:57 epatto1 NetworkManager: <info>  SUP: response was 'OK' 
Jun 10 18:16:57 epatto1 NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 psk <key>' 
Jun 10 18:16:57 epatto1 NetworkManager: <info>  SUP: response was 'OK' 
Jun 10 18:16:58 epatto1 avahi-daemon[2782]: Joining mDNS multicast group on
interface ath0.IPv6 with address fe80::416:cbff:feb5:f332.
Jun 10 18:16:58 epatto1 NetworkManager: <info>  SUP: sending command
'ENABLE_NETWORK 0' 
Jun 10 18:16:58 epatto1 avahi-daemon[2782]: New relevant interface ath0.IPv6 for
mDNS.
Jun 10 18:16:58 epatto1 NetworkManager: <info>  SUP: response was 'OK' 
Jun 10 18:16:58 epatto1 avahi-daemon[2782]: Registering new address record for
fe80::416:cbff:feb5:f332 on ath0.*.
Jun 10 18:16:58 epatto1 NetworkManager: <info>  Activation (ath0) Stage 2 of 5
(Device Configure) complete. 
Jun 10 18:17:07 epatto1 NetworkManager: <info>  Old device 'ath0' activating,
won't change. 
Jun 10 18:17:25 epatto1 NetworkManager: <info>  Old device 'ath0' activating,
won't change. 
Jun 10 18:17:32 epatto1 NetworkManager: <info>  Activation (ath0/wireless):
association took too long (>40s), failing activation. 
Jun 10 18:17:33 epatto1 NetworkManager: <info>  Activation (ath0) failure
scheduled... 
Jun 10 18:17:33 epatto1 NetworkManager: <info>  Activation (ath0) failed for
access point (epatto) 
Jun 10 18:17:33 epatto1 NetworkManager: <info>  Activation (ath0) failed. 
Jun 10 18:17:33 epatto1 NetworkManager: <info>  Deactivating device ath0. 
Jun 10 18:17:33 epatto1 avahi-daemon[2782]: Withdrawing address record for
fe80::416:cbff:feb5:f332 on ath0.
Jun 10 18:17:33 epatto1 avahi-daemon[2782]: Leaving mDNS multicast group on
interface ath0.IPv6 with address fe80::416:cbff:feb5:f332.
Jun 10 18:17:33 epatto1 avahi-daemon[2782]: Interface ath0.IPv6 no longer
relevant for mDNS.

I am randomly able to make a connection. It looks like I have better chances of
getting a connection when I wait for a while before entering the password for my
keyring (so that all the applets have started). I am not sure how relevant this
is... Also, after a failed connect, if I kill NetworkManager & dispatcher
and restart them, I often get a good connection. I just disabled dhcp and
this seems to increase the chances of connection.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Russell Harrison 2007-08-21 18:41:34 EDT
I'm seeing the same problem with both the 3945 and the 4965
Comment 2 Jussi Eloranta 2007-10-31 00:49:12 EDT
I think I found the problem. It is not related to wpa2 but to some sort of
transfer speed negotiation problem in madwifi. If I have iwpriv ath0 mode 3
in my rc scripts, everything works OK.

So, since this is a madwifi problem, we can close this bug?
Comment 3 Jussi Eloranta 2007-10-31 00:49:59 EDT
Sorry, forgot to say that the iwpriv command disables autonegotiation and sets a
specific speed for the link.
Comment 4 Dan Williams 2007-10-31 20:58:34 EDT
A madwifi bug then.  You might also try the ath5k driver in recent Fedora
kernels too.  That uses the standard linux mac80211 stack (instead of being
out-of-tree) and therefore will work much better with NetworkManager.

Note You need to log in before you can comment on or make changes to this bug.