Bug 244498 - grubby error on kernel install
Summary: grubby error on kernel install
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-16 06:16 UTC by Neil Thompson
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 08:50:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neil Thompson 2007-06-16 06:16:43 UTC
Description of problem:
When yum updating kernel to latest (2.6.21-1.3228.fc7), I get the following error -

Installing: kernel                       ####################### [25/71] 
grubby fatal error: unable to find a suitable template
 
and no grub entry is created for the kernel. 

Version-Release number of selected component (if applicable):
mkinitrd-6.0.9-7.1.i386

This is on a system upgraded from FC6

Comment 1 Neil Thompson 2007-06-20 05:24:37 UTC
Something that may also pertain - when I upgraded from FC6, the grub entry was
incorrect after the upgrade; it was still pointing at the (then deleted) FC6
kernel.  Also, my boot partition was no longer used.  This was an anaconda upgrade.

Comment 2 Neil Thompson 2007-07-11 05:35:02 UTC
Ping...is there anyone out there?

Comment 3 Neil Thompson 2007-07-21 09:14:16 UTC
OK, it's happened again with kernel-2.6.22.1-27.fc7.

I'm not sure whether it's any use continuing entering stuff here as no-one seems
to be taking any notice. 

Comment 4 Neil Thompson 2007-07-23 08:50:02 UTC
This turned out to be caused by anaconda having messed up my partitions during
the upgrade - it totally ignored the presense of my /boot partition and created
a /boot directory on my / partition without updating grub.conf.  grubby was
reading grub.conf and trying to find vmlinuz.(whatever) directly under hd2 (/
partition) and failing with the "unable to find a suitable template" error. 

A more explanatory error message like "Unable to find kernel file -
/vmlinuz.(whatever)" would have helped.  I'll see if I can't patch up grubby to
display that message and update the bug with the patch.

Comment 5 Askar Ali Khan 2007-07-29 14:23:58 UTC
Got the same error when today I installed kernel update using 'yum -y update'

Kernel-2.6.22.1-33.fc7 has been installed but no grub enter created :-s, however
i can see the kernel files in /boot.

We are using kernel-xen but love to keep normal kernel for fallback and today we
lost that kernel entry from grub.conf :(

Regards, 


Note You need to log in before you can comment on or make changes to this bug.