Bug 244510 - avoid build with python 2.4
Summary: avoid build with python 2.4
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jonathan Steffan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-16 11:18 UTC by Frank Büttner
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 22:52:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Büttner 2007-06-16 11:18:06 UTC
Description of problem:
It is possible to build it with python 2.4 but after build it will not run.
So I thing it is needed to modify the spec file and add python => 2.5.

Version-Release number of selected component (if applicable):
2.0.3.9-1

Comment 1 Jonathan Steffan 2007-06-16 21:12:18 UTC
What version of fedora did you build on?

Comment 2 Frank Büttner 2007-06-16 21:21:17 UTC
I have try to build it under FC6. The build process will work, bur when you try
to start it, you will get only an syntax error.

Comment 3 Jonathan Steffan 2007-06-16 21:38:01 UTC
I suspected so. Revisor is known not running on FC6. IIRC, it is not due to the
python version it is due to the pykickstart version.

Comment 4 Jeroen van Meeuwen 2007-06-16 22:52:36 UTC
pykickstart, system-config-kickstart, anaconda, anaconda-runtime, python, pungi
and livecd-tools actually ;-) I'm adding a requirement to fedora-release >= 7


Note You need to log in before you can comment on or make changes to this bug.