Bug 244521 - CD-ROM drive no longer recognised.
CD-ROM drive no longer recognised.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-16 13:00 EDT by Andrew Clayton
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-22 13:23:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of dmesg under F7 (19.68 KB, text/plain)
2007-06-16 13:00 EDT, Andrew Clayton
no flags Details

  None (edit)
Description Andrew Clayton 2007-06-16 13:00:15 EDT
Description of problem:

After doing a fresh install of Fedora 7 on my laptop (Fujitsu Siemens Lifebook
C1020) . The internal cdrom drive seems to be no longer found. dmesg (attached)
doesn't seem to show it, there's no /proc/sys/dev/cdrom directory and no cdrom
device files in /dev 


Version-Release number of selected component (if applicable):

kernel-2.6.21-1.3228.fc7.i686


Heres the output from lspci

00:00.0 Host bridge: VIA Technologies, Inc. P4M266 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus
Controller (rev 01)
00:0a.1 CardBus bridge: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus
Controller (rev 01)
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 23)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 23)
00:11.4 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 23)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 30)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller
(rev 70)
01:00.0 VGA compatible controller: S3 Inc. VT8375 [ProSavage8 KM266/KL266]
Comment 1 Andrew Clayton 2007-06-16 13:00:15 EDT
Created attachment 157198 [details]
Output of dmesg under F7
Comment 2 Andrew Clayton 2007-07-22 13:23:35 EDT
With the 2.6.22 Fedora 7 kernel update the drive is now recognized. However it
doesn't actually work. Opening up a new bug ticket for it, #249209


Note You need to log in before you can comment on or make changes to this bug.