Bug 244535 - Problems with sound input/output on emu10k after upgrade from FC6 to FC7
Problems with sound input/output on emu10k after upgrade from FC6 to FC7
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-16 16:18 EDT by Vladimir Kotal
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-16 18:13:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log generated via system-config-soundcard (59.03 KB, application/octet-stream)
2007-06-16 16:21 EDT, Vladimir Kotal
no flags Details

  None (edit)
Description Vladimir Kotal 2007-06-16 16:18:49 EDT
Description of problem:
After upgrade from FC6 to FC7 I have following problems with emu10k (Sound
Blaster Live! 5.1):
  1. no sound output from Center speaker
  2. sound now comes out of different connector
  3. cannot record sound

Version-Release number of selected component (if applicable):

[techie@erazim ~]$ rpm -q kernel alsa-lib alsa-utils
kernel-2.6.21-1.3194.fc7
kernel-2.6.21-1.3228.fc7
alsa-lib-1.0.14-0.4.rc3.fc7
alsa-utils-1.0.14-0.5.rc2.fc7
[techie@erazim ~]$ uname -a
Linux erazim.local.lab.devnull.cz 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 15:37:31
EDT 2007 i686 athlon i386 GNU/Linux


How reproducible:
play or record sounds

  
Actual results:
Sound output lacks central speaker and sound recording does not work.

Expected results:
Sound output and input should work as it worked in FC6.

Additional info:
On my SoundBlaster Live! sound card there are following jacks/connectors: (from
left to right)

- black
- green
- red
- blue
- orange

In FC6 I have used black+orange to get sound output. black was all 5 speakers,
orange was central speaker. All worked flawlessly. After upgrade to FC7 the
sound no longer comes from the black output but from the green output. Also, no
sound (or very very weak and with noise) comes out from the orange speaker.

I have booted Ubuntu LiveCD to see if this is really software problem and yes,
it is behaving in the same way as FC7.

The recording problem is this: I am able to hear myself in the speakers when I
speak into the microphone. Also, when I set microphone boost (+20dB) I begin to
hear back-coupling in the speakers. So, microphone works correctly as does the
input port on the sound card but somehow (the driver ?) it does not get the
sound any further. I am pretty sure I have seen bugs like that in ALSA before.

I have also tried to regenerate config files in system-config-soundcard and
reboot afterwards but it did not fix the problem.
Comment 1 Vladimir Kotal 2007-06-16 16:21:27 EDT
Created attachment 157204 [details]
scsconfig.log generated via system-config-soundcard
Comment 2 Vladimir Kotal 2007-06-16 17:36:11 EDT
I have bumped 'Wave Center' in alsamixer to value 82 and I can hear the Center
again. I have played with other settings in alsamixer as well and now the black
socket offers sound output as well.

Seems like alsamixer settings got garbled during upgrade. (or the format
changed, etc.)
Comment 3 Vladimir Kotal 2007-06-16 17:48:50 EDT
I have got the recording back as well, although I am not sure what was required
to get it working. (probably 'Wave capture') Clearly something has changed
between FC6 and FC7 so this should be at least reclassified as some sort of
upgrade bug.
Comment 4 Christopher Brown 2007-09-16 18:13:42 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

This bug appears to be resolved and I am therefore closing it. If I have erred,
please forgive me and re-open with any additional information you are able to
give. I will then try and assist you if I can.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.